aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-20 00:50:06 -0400
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:42:29 +0200
commitb17cdf3c90456a72f0d04425e60a57d896d7f8f9 (patch)
treeb95dc3366a3af06c6223add7447c5c6c29a20a0b /gnu
parent9eb56822f783b59643532c5b1dfc4d451bfd0ab7 (diff)
downloadguix-b17cdf3c90456a72f0d04425e60a57d896d7f8f9.tar
guix-b17cdf3c90456a72f0d04425e60a57d896d7f8f9.tar.gz
gnu: frozen-bubble: Add bash-minimal to inputs.
* gnu/packages/games.scm (frozen-bubble) [inputs]: Add bash-minimal. Drop labels. [arguments]: Delete trailing #t. Change-Id: I4dbcbe1626877b810b8a6e6b84ed78a16dea73a7
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm26
1 files changed, 12 insertions, 14 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 36ba1ddf5f..2c864c9287 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -8705,8 +8705,7 @@ when packaged in Blorb container files or optionally from individual files.")
(add-after 'unpack 'prevent-build-error
(lambda _
(substitute* "inc/My/Builder.pm"
- (("-Werror") ""))
- #t))
+ (("-Werror") ""))))
(add-after 'install 'install-desktop-file-and-icons
(lambda* (#:key outputs #:allow-other-keys)
(let* ((share (string-append (assoc-ref outputs "out") "/share"))
@@ -8729,8 +8728,7 @@ when packaged in Blorb container files or optionally from individual files.")
(copy-file
(string-append "frozen-bubble-icon-" dim ".png")
(string-append dir "/frozen-bubble.png"))))
- '("16" "32" "48" "64"))))
- #t))
+ '("16" "32" "48" "64"))))))
(add-after 'install 'wrap-perl-libs
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
@@ -8740,20 +8738,20 @@ when packaged in Blorb container files or optionally from individual files.")
`("PERL5LIB" ":" prefix
(,(string-append perl5lib ":" out
"/lib/perl5/site_perl")))))
- (find-files "bin" ".")))
- #t)))))
+ (find-files "bin" "."))))))))
(native-inputs
(list perl-alien-sdl perl-capture-tiny perl-locale-maketext-lexicon
perl-module-build pkg-config))
(inputs
- `(("glib" ,glib)
- ("perl-compress-bzip2" ,perl-compress-bzip2)
- ("perl-file-sharedir" ,perl-file-sharedir)
- ("perl-file-slurp" ,perl-file-slurp)
- ("perl-file-which" ,perl-file-which)
- ("perl-ipc-system-simple" ,perl-ipc-system-simple)
- ("perl-sdl" ,perl-sdl)
- ("sdl" ,(sdl-union (list sdl sdl-image sdl-mixer sdl-pango sdl-ttf)))))
+ (list bash-minimal
+ glib
+ perl-compress-bzip2
+ perl-file-sharedir
+ perl-file-slurp
+ perl-file-which
+ perl-ipc-system-simple
+ perl-sdl
+ (sdl-union (list sdl sdl-image sdl-mixer sdl-pango sdl-ttf))))
(home-page "http://frozen-bubble.org/")
(synopsis "Puzzle with bubbles")
(description