aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-12 23:02:50 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-15 12:17:51 +0100
commita82f7e68a676f7b9caf1ac23ea31d3a91c75f6ed (patch)
tree78fc26e8b5b3b7755a8bb5904a390a3809374498 /gnu
parente5be40522e59b468c6d4e68c4f049cf00357f013 (diff)
downloadguix-a82f7e68a676f7b9caf1ac23ea31d3a91c75f6ed.tar
guix-a82f7e68a676f7b9caf1ac23ea31d3a91c75f6ed.tar.gz
gnu: Add go-github-com-go-jose-go-jose-v4.
* gnu/packages/golang-web.scm (go-github-com-go-jose-go-jose-v4): New variable. Change-Id: I5edfc5e413cc50c010aab1ad4a189afabf5cd640
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-web.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index b3cc543849..0fb966ed79 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -812,6 +812,24 @@ Signing and Encryption set of standards. This includes support for JSON Web
Encryption, JSON Web Signature, and JSON Web Token standards.")
(license license:asl2.0)))
+(define-public go-github-com-go-jose-go-jose-v4
+ (package
+ (inherit go-github-com-go-jose-go-jose-v3)
+ (name "go-github-com-go-jose-go-jose-v4")
+ (version "4.0.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/go-jose/go-jose")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1bf444687q5rdxjgk41bkryhzhx49f6600b7i51m572xdl0r28a9"))))
+ (arguments
+ (list
+ #:import-path "github.com/go-jose/go-jose/v4"))))
+
(define-public go-github-com-go-ldap-ldap
(package
(name "go-github-com-go-ldap-ldap")