aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:54:05 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:55 +0000
commit473800b8effd43441a15fe77081500fb3abed0a9 (patch)
tree36503fe0a5084f2f275c212bb12297d8934fcd87 /gnu
parent5bcbe34fd1fdedded8d865ecab20a38895518252 (diff)
downloadguix-473800b8effd43441a15fe77081500fb3abed0a9.tar
guix-473800b8effd43441a15fe77081500fb3abed0a9.tar.gz
gnu: python-cmd2: Move to pyproject-build-system.
* gnu/packages/python-xyz.scm (python-cmd2): [build-system]: Move to pyproject-build-system. [arguments]<#:phases>: Remove check phase replacement. <#:test-flags>: Add field. Change-Id: I55b4134fb6caa4af1a4988934043487fa85f9b9b Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm14
1 files changed, 3 insertions, 11 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 086fb62516..914463fb12 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -32649,18 +32649,10 @@ intended for validating data coming into Python as JSON, YAML, etc.")
(sha256
(base32
"0h1naik558qh48gx2iyy0a0khvw5fz0in69y84mbrhsm9nq7w3bm"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (if tests?
- (invoke "pytest" "-vv" "-k"
- ;; These tests fail because no EDITOR is in PATH.
- "not test_find_editor_not_specified \
-and not test_transcript")
- (format #t "test suite not run~%")))))))
+ (list #:test-flags '(list "-k" "not test_find_editor_not_specified \
+and not test_transcript")))
(propagated-inputs
(list python-attrs python-colorama python-pyperclip python-wcwidth))
(native-inputs