aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-05-18 14:11:01 -0400
committerLudovic Courtès <ludo@gnu.org>2022-05-22 01:07:53 +0200
commit31ee69721ae33ae883c8adbfd4ac0663ccad4fea (patch)
tree26533102f25ead38331f0d71f56564f48b4615fd /gnu
parentc69d91a1b58ef21bbb59ac764337115b7d3b0963 (diff)
downloadguix-31ee69721ae33ae883c8adbfd4ac0663ccad4fea.tar
guix-31ee69721ae33ae883c8adbfd4ac0663ccad4fea.tar.gz
gnu: Add elm-url.
* gnu/packages/elm.scm (elm-url): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/elm.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/elm.scm b/gnu/packages/elm.scm
index 2b9ee3594a..d7d11e0d91 100644
--- a/gnu/packages/elm.scm
+++ b/gnu/packages/elm.scm
@@ -239,3 +239,31 @@ library.")
"This package provides an Elm library for working with POSIX times, time
zones, formatting, and the clock.")
(license license:bsd-3)))
+
+(define-public elm-url
+ (package
+ (name "elm-url")
+ (version "1.0.0")
+ (source
+ (elm-package-origin
+ "elm/url"
+ version
+ (base32 "1f2ij4i7zmijnj2i50qf19lpkr14bhms8dkq029inb5mydi9f8gs")))
+ (build-system elm-build-system)
+ (propagated-inputs (list elm-core))
+ (home-page "https://package.elm-lang.org/packages/elm/url/1.0.0")
+ (synopsis
+ "Create and parse URLs in Elm")
+ (description
+ "This package helps you:
+
+@enumerate
+@item
+build new URLs; and
+
+@item
+parse existing URLs into nice Elm data structures.
+@end enumerate
+
+Use it for HTTP and for @dfn{routing} in @acronym{SPAs, single-page apps}.")
+ (license license:bsd-3)))