aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-05-18 14:11:05 -0400
committerLudovic Courtès <ludo@gnu.org>2022-05-22 01:07:54 +0200
commit2ea11208f24a23d5aa9dd4b8639f0eec44c86705 (patch)
tree8d78d8c239ccbdf90ba7a24a0cba48663d36a6b4 /gnu
parent324b404804d46e95a37bad778e8aae90d8d575fc (diff)
downloadguix-2ea11208f24a23d5aa9dd4b8639f0eec44c86705.tar
guix-2ea11208f24a23d5aa9dd4b8639f0eec44c86705.tar.gz
gnu: Add elm-http.
* gnu/packages/elm.scm (elm-http): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/elm.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/elm.scm b/gnu/packages/elm.scm
index 3bf3b66a6e..68636c3192 100644
--- a/gnu/packages/elm.scm
+++ b/gnu/packages/elm.scm
@@ -331,3 +331,24 @@ and @code{DataView}.")
(description "This package enables Elm programs to select files, download
files, and work with file content.")
(license license:bsd-3)))
+
+(define-public elm-http
+ (package
+ (name "elm-http")
+ (version "2.0.0")
+ (source
+ (elm-package-origin
+ "elm/http"
+ version
+ (base32 "0mfbz0lkfidmq5xpv5csw8943q0yrpvj0rwd2vb0gc8rbsfc9dg8")))
+ (build-system elm-build-system)
+ (propagated-inputs
+ (list elm-json
+ elm-file
+ elm-core
+ elm-bytes))
+ (home-page "https://package.elm-lang.org/packages/elm/http/2.0.0")
+ (synopsis "Make HTTP requests in Elm")
+ (description "This package enables Elm programs to make HTTP requests and
+talk to servers.")
+ (license license:bsd-3)))