aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-03-26 19:46:14 +0100
committerChristopher Baines <mail@cbaines.net>2018-03-26 19:52:06 +0100
commit158943f2288fa07562df044b68396cee83d18eba (patch)
tree6e6bba2cced17c75817363196b4f87cc680260b5 /gnu
parent5b5dbece6bbfa7ecc153586b1ff7eb094c50bc48 (diff)
downloadguix-158943f2288fa07562df044b68396cee83d18eba.tar
guix-158943f2288fa07562df044b68396cee83d18eba.tar.gz
gnu: emacs-minitest: Switch source to the git repository.
The 0.8.0 release was over 3 years ago, and there have been ~50 commits since. * gnu/packages/emacs.scm (emacs-minitest): Wrap with let, and change source to the git repository.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm50
1 files changed, 26 insertions, 24 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index b99c4e01af..c4c2c386ec 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1828,34 +1828,36 @@ of files under Git version control from within Emacs.")
(license license:gpl3+)))
(define-public emacs-minitest
- (package
- (name "emacs-minitest")
- (version "0.8.0")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/arthurnn/minitest-emacs/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1dsb7kzvs1x6g4sgqmq73jqacb7wzm0wfkiq5m9dqdzq8mppgiqs"))))
- (build-system emacs-build-system)
- (arguments
- '(#:include (cons "^snippets\\/minitest-mode\\/" %default-include)
- #:exclude (delete "^[^/]*tests?\\.el$" %default-exclude)))
- (propagated-inputs
- `(("emacs-dash" ,emacs-dash)
- ("emacs-f" ,emacs-f)))
- (home-page "https://github.com/arthurnn/minitest-emacs")
- (synopsis "Emacs minitest mode")
- (description
- "The minitest mode provides commands to run the tests for the current
+ (let ((commit "1aadb7865c1dc69c201cecee275751ecec33a182")
+ (revision "1"))
+ (package
+ (name "emacs-minitest")
+ (version (git-version "0.8.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/arthurnn/minitest-emacs")
+ (commit commit)))
+ (file-name (git-file-name name commit))
+ (sha256
+ (base32
+ "1l18zqpdzbnqj2qawq8hj7z7pl8hr8z9d8ihy8jaiqma915hmhj1"))))
+ (build-system emacs-build-system)
+ (arguments
+ '(#:include (cons "^snippets\\/minitest-mode\\/" %default-include)
+ #:exclude (delete "^[^/]*tests?\\.el$" %default-exclude)))
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)
+ ("emacs-f" ,emacs-f)))
+ (home-page "https://github.com/arthurnn/minitest-emacs")
+ (synopsis "Emacs minitest mode")
+ (description
+ "The minitest mode provides commands to run the tests for the current
file or line, as well as rerunning the previous tests, or all the tests for a
project.
This package also includes relevant snippets for yasnippet.")
- (license license:expat)))
+ (license license:expat))))
(define-public emacs-el-mock
(package