aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 15:02:58 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commit766504d19996eb531a542cf8b2ef7ade0e737e91 (patch)
tree55fff225dffd1a5836d0ec7e907a47ad8161980a /gnu
parent7cfdbc514f5b558cdae16e87f66774bd033fbc6d (diff)
downloadguix-766504d19996eb531a542cf8b2ef7ade0e737e91.tar
guix-766504d19996eb531a542cf8b2ef7ade0e737e91.tar.gz
gnu: Add ghc-tasty-hunit.
* gnu/packages/haskell.scm (ghc-tasty-hunit): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 8c1e6f799d..bebeda52c6 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -2863,4 +2863,27 @@ you combine your unit tests, golden tests, QuickCheck/SmallCheck properties,
and any other types of tests into a single test suite.")
(license expat)))
+(define-public ghc-tasty-hunit
+ (package
+ (name "ghc-tasty-hunit")
+ (version "0.9.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/tasty-hunit/tasty-hunit-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "08qnxaw34wfnzi9irs1jd4d0zczqm3k5ffkd4zwhkz0dflmgq7mf"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-tasty" ,ghc-tasty)))
+ (home-page "http://documentup.com/feuerbach/tasty")
+ (synopsis "HUnit support for the Tasty test framework")
+ (description "This package provides HUnit support for the Tasty Haskell
+test framework.")
+ (license expat)))
+
;;; haskell.scm ends here