aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-12-19 20:12:46 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-12-19 20:35:07 +0100
commit02cdb45f345da30a04c384b6763e9f9dc6503801 (patch)
tree36281f027c9cdefd233b8199129e556b00885a79 /gnu
parent5378f38332b5730d34f8dbd5dab71a547b6dcf02 (diff)
downloadguix-02cdb45f345da30a04c384b6763e9f9dc6503801.tar
guix-02cdb45f345da30a04c384b6763e9f9dc6503801.tar.gz
gnu: Add r-truncnorm.
* gnu/packages/cran.scm (r-truncnorm): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index a52a4e928c..eafc489deb 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1444,6 +1444,26 @@ imputations.")
;; Any of these two versions.
(license (list license:gpl2 license:gpl3))))
+(define-public r-truncnorm
+ (package
+ (name "r-truncnorm")
+ (version "1.0-7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "truncnorm" version))
+ (sha256
+ (base32
+ "1qac05z50618y4bw1d7yznsli1bv82s0g8h37iacrjrdkv87bmy7"))))
+ (build-system r-build-system)
+ (home-page "http://cran.r-project.org/web/packages/truncnorm/")
+ (synopsis "Truncated normal distribution")
+ (description "This package provides functions for the truncated normal
+distribution with mean equal to @code{mean} and standard deviation equal to
+@code{sd}. It includes density, distribution, quantile, and expected value
+functions, as well as a random generation function.")
+ (license license:gpl2)))
+
(define-public r-hardyweinberg
(package
(name "r-hardyweinberg")