aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-10-02 23:15:14 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 22:31:08 +0100
commitce40b3839535c4858bec61ac23a557fca4c79cc0 (patch)
treec2b33ad795c499fc06a488b4c77995453f7749ce /gnu
parentb3e8b4bd0f390784c710944c9962a0e13b25ed02 (diff)
downloadguix-ce40b3839535c4858bec61ac23a557fca4c79cc0.tar
guix-ce40b3839535c4858bec61ac23a557fca4c79cc0.tar.gz
gnu: python-pytest-cov: Use upstream options for testing.
* gnu/packages/python.scm (python-pytest-cov): Replace phase "check" by one passing the options found in upstream's tox.ini-file to "python setup.py check".
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 2f7ae95fa4..b0c1411c22 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1662,6 +1662,16 @@ and many external plugins.")
(base32
"1yl4nbhzfgsxqlsyk4clafgp9x11zvgrkprm9i2p3fgkwx9jxcm8"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ ;; options taken from tox.ini
+ ;; TODO: make "--restructuredtext" tests pass. They currently fail
+ ;; with "Duplicate implicit target name"
+ (zero? (system* "python" "./setup.py" "check"
+ "--strict" "--metadata")))))))
(propagated-inputs
`(("python-coverage" ,python-coverage)
("python-pytest" ,python-pytest)))