aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2016-05-26 02:56:19 +0200
committerLeo Famulari <leo@famulari.name>2016-05-31 17:21:11 -0400
commitf40dfcd055213c14c51c8117ce03d63f4820c4b5 (patch)
tree3bbbc81e7066c0d5bcdc0f3feaa6b8ffa8c5adaa /gnu
parent37dbfc50841a8e91f9fb0dc80ff9b5f23de38689 (diff)
downloadguix-f40dfcd055213c14c51c8117ce03d63f4820c4b5.tar
guix-f40dfcd055213c14c51c8117ce03d63f4820c4b5.tar.gz
gnu: rofi: New variable.
* gnu/packages/xdisorg.scm (rofi): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xdisorg.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 6059da935f..1ece2e164b 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -910,3 +910,44 @@ demos. It also acts as a nice screen locker.")
(string-append
"http://metadata.ftp-master.debian.org/changelogs/"
"/main/x/xscreensaver/xscreensaver_5.34-2_copyright")))))
+
+(define-public rofi
+ (package
+ (name "rofi")
+ (version "1.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/DaveDavenport/rofi/"
+ "releases/download/"
+ version "/rofi-" version ".tar.xz"))
+ (sha256
+ (base32
+ "01jxml9vk4cw7pngpan7dipmb98s6ibh6f0023lw3hbgxy650637"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("libx11" ,libx11)
+ ("pango" ,pango)
+ ("cairo" ,cairo)
+ ("glib" ,glib)
+ ("startup-notification" ,startup-notification)
+ ("libxkbcommon" ,libxkbcommon)
+ ("libxcb" ,libxcb)
+ ("xcb-util" ,xcb-util)
+ ("xcb-util-wm" ,xcb-util-wm)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'adjust-tests
+ (lambda _
+ (substitute* '("test/helper-expand.c")
+ (("~root") "/root")
+ (("~") "")
+ (("g_get_home_dir \\(\\)") "\"/\"")))))))
+ (home-page "https://davedavenport.github.io/rofi/")
+ (synopsis "Application Launcher")
+ (description "Rofi is a minimalist Application Launcher. It memorizes which
+applications you regularily use and also allows you to search for an application
+by name.")
+ (license license:expat)))