aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPierre Neidhardt <ambrevar@gmail.com>2018-04-09 23:01:04 +0530
committerLudovic Courtès <ludo@gnu.org>2018-04-19 11:53:58 +0200
commitb164233851df8961cd112d65900c6afb08e88a8c (patch)
tree554fba4aa9e9db73030ea022afb876f8906f9f76 /gnu
parent9a3fb60ca30246456b2f9a4d9406ef416dfb55f9 (diff)
downloadguix-b164233851df8961cd112d65900c6afb08e88a8c.tar
guix-b164233851df8961cd112d65900c6afb08e88a8c.tar.gz
gnu: Add fortune-mod.
* gnu/packages/games.scm (fortune-mod): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm54
1 files changed, 54 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index b7eda0fdc4..f34beae3df 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -112,6 +112,7 @@
#:use-module (gnu packages gstreamer)
#:use-module (gnu packages bash)
#:use-module (gnu packages perl)
+ #:use-module (gnu packages perl-check)
#:use-module (gnu packages qt)
#:use-module (gnu packages compression)
#:use-module (gnu packages pulseaudio)
@@ -4852,3 +4853,56 @@ Strife, Chex Quest, and fan-created games like Harmony, Hacx and Freedoom.")
(license:non-copyleft ; modified dumb
"file://dumb/licence.txt"
"Dumb license, explicitly GPL compatible.")))))
+
+(define-public fortune-mod
+ (package
+ (name "fortune-mod")
+ (version "2.4.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/shlomif/fortune-mod/"
+ "archive/" name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1hnqpkassh7fwg2jgvybr8mw7vzfikbrhb5r22367ilfwxnl9yd2"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:test-target "check"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-build-env
+ (lambda* (#:key inputs #:allow-other-keys)
+ (use-modules (guix build utils))
+ (let* ((cmake-rules (assoc-ref inputs "cmake-rules")))
+ (copy-file cmake-rules
+ (string-append "fortune-mod/cmake/"
+ (strip-store-file-name cmake-rules)))
+ (chdir "fortune-mod"))))
+ (add-after 'install 'fix-install-directory
+ ;; Move binary from "games/" to "bin/".
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (rename-file (string-append out "/games/fortune")
+ (string-append out "/bin/fortune"))
+ #t))))))
+ (inputs `(("recode" ,recode)))
+ (native-inputs
+ `(("perl" ,perl)
+ ;; The following is only needed for tests.
+ ("perl-file-find-object" ,perl-file-find-object)
+ ("perl-test-differences" ,perl-test-differences)
+ ("perl-class-xsaccessor" ,perl-class-xsaccessor)
+ ("perl-io-all" ,perl-io-all)
+ ("perl-test-runvalgrind" ,perl-test-runvalgrind)
+ ("cmake-rules"
+ ,(origin
+ (method url-fetch)
+ (uri (string-append "https://bitbucket.org/shlomif/shlomif-cmake-modules/"
+ "raw/default/shlomif-cmake-modules/Shlomif_Common.cmake"))
+ (sha256
+ (base32 "0kx9s1qqhhzprp1w3b67xmsns0n0v506bg5hgrshxaxpy6lqiwb2"))))))
+ (home-page "http://www.shlomifish.org/open-source/projects/fortune-mod/")
+ (synopsis "The Fortune Cookie program from BSD games")
+ (description "Fortune is a command-line utility which displays a random
+quotation from a collection of quotes.")
+ (license license:bsd-4)))