aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-11-18 18:42:02 -0600
committerEric Bavier <bavier@member.fsf.org>2015-11-19 03:13:19 -0600
commitab715ec9ae8b9762662a6efbab35a2733952c9e6 (patch)
tree5598aa72ee4caefe5b677fff33b576dac32aa847 /gnu
parente1c1b71c38cacecce168752a72f466506caf2b45 (diff)
downloadguix-ab715ec9ae8b9762662a6efbab35a2733952c9e6.tar
guix-ab715ec9ae8b9762662a6efbab35a2733952c9e6.tar.gz
gnu: Add ghc-test-framework-quickcheck2.
* gnu/packages/haskell.scm (ghc-test-framework-quickcheck2): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 1ef74fb8c6..2cb25de45f 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1779,6 +1779,39 @@ reporting and test statistics output.")
"This package provides HUnit support for the test-framework package.")
(license bsd-3)))
+(define-public ghc-test-framework-quickcheck2
+ (package
+ (name "ghc-test-framework-quickcheck2")
+ (version "0.3.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://hackage.haskell.org/package/"
+ "test-framework-quickcheck2/"
+ "test-framework-quickcheck2-" version ".tar.gz"))
+ (sha256
+ (base32
+ "12p1zwrsz35r3j5gzbvixz9z1h5643rhihf5gqznmc991krwd5nc"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; The Hackage page and the cabal file linked there for this package
+ ;; both list 2.9 as the upper version limit, but the source tarball
+ ;; specifies 2.8. Assume the Hackage page is correct.
+ '(substitute* "test-framework-quickcheck2.cabal"
+ (("QuickCheck >= 2.4 && < 2.8") "QuickCheck >= 2.4 && < 2.9")))))
+ (build-system haskell-build-system)
+ (propagated-inputs
+ `(("ghc-extensible-exceptions" ,ghc-extensible-exceptions)
+ ("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-random" ,ghc-random)
+ ("ghc-test-framework" ,ghc-test-framework)))
+ (home-page "https://batterseapower.github.io/test-framework/")
+ (synopsis "QuickCheck2 support for test-framework")
+ (description
+ "This packages provides QuickCheck2 support for the test-framework
+package.")
+ (license bsd-3)))
+
(define-public ghc-tf-random
(package
(name "ghc-tf-random")