aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-05-29 14:48:42 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-05-30 22:22:25 +0300
commit365a4a7f405b76b4f397e18a8cb1980654bf9db6 (patch)
treea6b97a252a735146355e7cee6887d8721e43b0e1 /gnu
parentfd1461879c63c608617d30524183a71370a7451c (diff)
downloadguix-365a4a7f405b76b4f397e18a8cb1980654bf9db6.tar
guix-365a4a7f405b76b4f397e18a8cb1980654bf9db6.tar.gz
gnu: Add zimg.
* gnu/packages/image.scm (zimg): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/image.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index eca9012bf8..0ab3f60c5e 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -767,3 +767,37 @@ implementation of the codec specified in the JPEG-2000 Part-1 standard (i.e.,
ISO/IEC 15444-1).")
(home-page "https://www.ece.uvic.ca/~frodo/jasper/")
(license (license:x11-style "file://LICENSE"))))
+
+(define-public zimg
+ (package
+ (name "zimg")
+ (version "2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/sekrit-twc/zimg/archive/"
+ "release-" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1hqp1gcsa2zhypms5dnasb1srjgxdqm7cip3w5i571kk9nxkn289"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'autogen
+ (lambda _
+ (zero? (system* "sh" "autogen.sh")))))))
+ (synopsis "Scaling, colorspace conversion, and dithering library")
+ (description "Zimg implements the commonly required image processing basics
+of scaling, colorspace conversion, and depth conversion. A simple API enables
+conversion between any supported formats to operate with minimal knowledge from
+the programmer.")
+ (home-page "https://github.com/sekrit-twc/zimg")
+ ;; test/extra/ contains musl-libm,
+ ;; which is MIT/expat licensed, but only used for tests
+ (license (license:fsf-free "file://COPYING")))) ;WTFPL version 2