aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-10-20 10:49:32 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-10-22 12:10:33 +0200
commit1ab867bebb78bb2efbe8e33c12e5f17b0e16a950 (patch)
treed1afe067ea5f3b7bb0ca6f436bb2dc1d10b2df2f /gnu
parent6efc99967800183daa74ba2ebff6185dfcf1b33d (diff)
downloadguix-1ab867bebb78bb2efbe8e33c12e5f17b0e16a950.tar
guix-1ab867bebb78bb2efbe8e33c12e5f17b0e16a950.tar.gz
gnu: Add r-pdist.
* gnu/packages/cran.scm (r-pdist): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index e00a8a4ba2..dba294c8d7 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1217,3 +1217,27 @@ initial data set and then applied to other data sets. The resulting design
matrices can then be used as inputs into statistical or machine learning
models.")
(license license:gpl2)))
+
+(define-public r-pdist
+ (package
+ (name "r-pdist")
+ (version "1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "pdist" version))
+ (sha256
+ (base32
+ "18nd3mgad11f2zmwcp0w3sxlch4a9y6wp8dfdyzvjn7y4b4bq0dd"))))
+ (build-system r-build-system)
+ (home-page "https://github.com/jeffwong/pdist")
+ (synopsis "Partitioned distance function")
+ (description
+ "Pdist computes the euclidean distance between rows of a matrix X and
+rows of another matrix Y. Previously, this could be done by binding the two
+matrices together and calling @code{dist}, but this creates unnecessary
+computation by computing the distances between a row of X and another row of
+X, and likewise for Y. Pdist strictly computes distances across the two
+matrices, not within the same matrix, making computations significantly faster
+for certain use cases.")
+ (license license:gpl3+)))