aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-11-18 18:05:24 -0600
committerEric Bavier <bavier@member.fsf.org>2015-11-19 03:13:19 -0600
commit09655c676be6ae7114ad8016e745dac315e769fe (patch)
tree33d5bc52647b24ae1ba915ea96b70a6c5a7e509d /gnu
parent1472ba25465df75d1d17c50e8c4db9cd71bd2343 (diff)
downloadguix-09655c676be6ae7114ad8016e745dac315e769fe.tar
guix-09655c676be6ae7114ad8016e745dac315e769fe.tar.gz
gnu: Add ghc-test-framework.
* gnu/packages/haskell.scm (ghc-test-framework): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 2e071abcc6..f3086b1fb7 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1720,6 +1720,41 @@ library, including the ability to split random number generators.")
"This package provides various primitive memory-related operations.")
(license bsd-3)))
+(define-public ghc-test-framework
+ (package
+ (name "ghc-test-framework")
+ (version "0.8.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://hackage.haskell.org/package/test-framework/"
+ "test-framework-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0wxjgdvb1c4ykazw774zlx86550848wbsvgjgcrdzcgbb9m650vq"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-hunit" ,ghc-hunit)
+ ("ghc-libxml" ,ghc-libxml)
+ ("ghc-quickcheck" ,ghc-quickcheck)))
+ (propagated-inputs
+ `(("ghc-ansi-terminal" ,ghc-ansi-terminal)
+ ("ghc-ansi-wl-pprint" ,ghc-ansi-wl-pprint)
+ ("ghc-hostname" ,ghc-hostname)
+ ("ghc-old-locale" ,ghc-old-locale)
+ ("ghc-random" ,ghc-random)
+ ("ghc-regex-posix" ,ghc-regex-posix)
+ ("ghc-xml" ,ghc-xml)))
+ (home-page "https://batterseapower.github.io/test-framework/")
+ (synopsis "Framework for running and organising tests")
+ (description
+ "This package allows tests such as QuickCheck properties and HUnit test
+cases to be assembled into test groups, run in parallel (but reported in
+deterministic order, to aid diff interpretation) and filtered and controlled
+by command line options. All of this comes with colored test output, progress
+reporting and test statistics output.")
+ (license bsd-3)))
+
(define-public ghc-tf-random
(package
(name "ghc-tf-random")