aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2015-12-28 00:22:34 -0500
committerLeo Famulari <leo@famulari.name>2015-12-29 19:55:21 -0500
commit6da16993eb7c35d829e947d65e57508fa5d1a00f (patch)
treea2c81185528aa2267d67a626d2a7c4ee2e2d485d /gnu
parent20b978192e18a0ce0e34da2123a1174ebbce183c (diff)
downloadguix-6da16993eb7c35d829e947d65e57508fa5d1a00f.tar
guix-6da16993eb7c35d829e947d65e57508fa5d1a00f.tar.gz
gnu: Add cuetools.
* gnu/packages/audio.scm (cuetools): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/audio.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 6a8347af05..652e229d9a 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1953,3 +1953,36 @@ access to ALSA PCM devices, taking care of the many functions required to
open, initialise and use a hw: device in mmap mode, and providing floating
point audio data.")
(license license:gpl3+)))
+
+(define-public cuetools
+ (package
+ (name "cuetools")
+ (version "1.4.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/svend/cuetools/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "01xi3rvdmil9nawsha04iagjylqr1l9v9vlzk99scs8c207l58i4"))))
+ (build-system gnu-build-system)
+ ;; The source tarball is not bootstrapped.
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'bootstrap
+ (lambda _ (zero? (system* "autoreconf" "-vfi")))))))
+ ;; Bootstrapping tools
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("flex" ,flex)
+ ("bison" ,bison)))
+ (synopsis "Cue and toc file parsers and utilities")
+ (description "Cuetools is a set of programs that are useful for manipulating
+and using CUE sheet (cue) files and Table of Contents (toc) files. CUE and TOC
+files are a way to represent the layout of a data or audio CD in a
+machine-readable ASCII format.")
+ (home-page "https://github.com/svend/cuetools")
+ (license license:gpl2+)))