aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-03-06 10:55:00 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-03-06 12:22:15 +0100
commitdf8a042de8aab0ae56b36155575173320a42a36a (patch)
tree7baadc9f490472de164326da75d87b2604948683 /gnu
parentb3fb3c10b8eb2347685544e4b8939c33ed1c2f04 (diff)
downloadguix-df8a042de8aab0ae56b36155575173320a42a36a.tar
guix-df8a042de8aab0ae56b36155575173320a42a36a.tar.gz
gnu: texlive-latex-auxhook: Rename to texlive-auxhook.
* gnu/packages/tex.scm (texlive-auxhook): New variable. (texlive-latex-auxhook): Deprecated alias. (texlive-hyperref): Use new name.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm54
1 files changed, 39 insertions, 15 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a8b4dbcd3c..be34ccf711 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3108,21 +3108,45 @@ the @file{.aux} file.")
(define-deprecated-package texlive-latex-atveryend texlive-atveryend)
-(define-public texlive-latex-auxhook
- (package
- (inherit (simple-texlive-package
- "texlive-latex-auxhook"
- '("/doc/latex/auxhook/README.md"
- "/tex/latex/auxhook/")
- (base32
- "1xh445shr00rh43nnz03xh8k2mdrxgsr03lllqpgvwhm6yzsydkf")
- #:trivial? #t))
- (home-page "https://www.ctan.org/pkg/auxhook")
- (synopsis "Hooks for auxiliary files")
- (description
- "This package provides hooks for adding code at the beginning of
+(define-public texlive-auxhook
+ (let ((template (simple-texlive-package
+ "texlive-auxhook"
+ (list "doc/latex/auxhook/"
+ "source/latex/auxhook/"
+ "tex/latex/auxhook/")
+ (base32
+ "1qfs7bz8ryp4prr2fw4hwypnfc6yr4rc4wd8qy4rpmab0hab0vdy"))))
+ (package
+ (inherit template)
+ (outputs '("out" "doc"))
+ (arguments
+ (substitute-keyword-arguments (package-arguments template)
+ ((#:tex-directory _ '())
+ "latex/auxhook")
+ ((#:build-targets _ '())
+ #~(list "auxhook.dtx"))
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "source/latex/auxhook")))
+ (replace 'copy-files
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((origin (assoc-ref inputs "source"))
+ (source (string-append #$output
+ "/share/texmf-dist/source"))
+ (doc (string-append #$output:doc
+ "/share/texmf-dist/doc")))
+ (copy-recursively (string-append origin "/source") source)
+ (copy-recursively (string-append origin "/doc") doc))))))))
+ (home-page "https://www.ctan.org/pkg/auxhook")
+ (synopsis "Hooks for auxiliary files")
+ (description
+ "This package provides hooks for adding code at the beginning of
@file{.aux} files.")
- (license license:lppl1.3c+)))
+ (license license:lppl1.3c+))))
+
+(define-deprecated-package texlive-latex-auxhook texlive-auxhook)
(define-public texlive-latex-epstopdf-pkg
(package
@@ -3467,7 +3491,7 @@ XML, using UTF-8 or a suitable 8-bit encoding.")
texlive-kvsetkeys
texlive-ltxcmds
texlive-pdfescape
- texlive-latex-auxhook
+ texlive-auxhook
texlive-latex-hycolor
texlive-latex-kvoptions
texlive-latex-letltxmacro