aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-07-11 16:36:42 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-07-12 14:29:09 +0200
commit990bac0ea5daae426801df9b64e67d51a9316d8d (patch)
treee1a36329811518659991bd349e04b52bbf31781c /gnu
parentb10bff65be21a284a80f21dacf3caeecba245092 (diff)
downloadguix-990bac0ea5daae426801df9b64e67d51a9316d8d.tar
guix-990bac0ea5daae426801df9b64e67d51a9316d8d.tar.gz
gnu: Add r-pfamanalyzer.
* gnu/packages/bioconductor.scm (r-pfamanalyzer): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 20add7af89..840a9cdde8 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -8313,6 +8313,29 @@ the results is also provided. All PCA methods make use of the same data
structure (pcaRes) to provide a common interface to the PCA results.")
(license license:gpl3+)))
+(define-public r-pfamanalyzer
+ (package
+ (name "r-pfamanalyzer")
+ (version "1.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "pfamAnalyzeR" version))
+ (sha256
+ (base32
+ "0zff887lc4bjrv683kqsw47vjwmf6886wybklsf2wd6hpy23mxfy"))))
+ (properties `((upstream-name . "pfamAnalyzeR")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-dplyr r-magrittr r-readr r-stringr r-tibble))
+ (native-inputs (list r-knitr))
+ (home-page "https://bioconductor.org/packages/pfamAnalyzeR")
+ (synopsis "Identification of domain isotypes in pfam data")
+ (description
+ "This R package enables the user to read pfam predictions into R. Most
+human protein domains exist as multiple distinct variants termed domain
+isotypes. This R package enables the identification and classification of such
+domain isotypes from pfam data.")
+ (license license:expat)))
+
;; This is a CRAN package, but it depends on a Bioconductor package:
;; r-aroma-light, r-dnacopy..
(define-public r-pscbs