aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-03-29 21:35:34 -0400
committerMark H Weaver <mhw@netris.org>2015-03-29 21:36:31 -0400
commite930c2a350ea7dd33df1293ea3b87c2206e9343c (patch)
treefee8ce103bec197f6b08d52b11f848f0c64479aa /gnu
parent18ad5bff7a3835d620ada1572ffef8a9efc97372 (diff)
downloadguix-e930c2a350ea7dd33df1293ea3b87c2206e9343c.tar
guix-e930c2a350ea7dd33df1293ea3b87c2206e9343c.tar.gz
gnu: liba52: Pass --build to configure.
* gnu/packages/video.scm (liba52)[arguments]: Pass --build to configure.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 4c3c3ec44b..bc589a6edb 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -24,6 +24,7 @@
#:use-module ((guix licenses)
#:select (gpl2 gpl2+ gpl3+ lgpl2.1+ bsd-3 public-domain
fsf-free isc))
+ #:use-module (guix utils)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
@@ -93,6 +94,13 @@
(base32
"0czccp4fcpf2ykp16xcrzdfmnircz1ynhls334q374xknd5747d2"))))
(build-system gnu-build-system)
+ (arguments `(#:configure-flags
+ '(;; FIXME: liba52-0.7.4's config.guess fails on mips64el.
+ ,@(if (%current-target-system)
+ '()
+ (let ((triplet
+ (nix-system->gnu-triplet (%current-system))))
+ (list (string-append "--build=" triplet)))))))
(home-page "http://liba52.sourceforge.net/")
(synopsis "ATSC A/52 stream decoder")
(description "liba52 is a library for decoding ATSC A/52 streams. The