aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-09-28 19:55:48 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-09-28 22:10:33 +0200
commitd1f1947a462eac5eef01fb1787fa22d1c801ced8 (patch)
treec02fdc7c66450deaaa0cd18d343dc31eab780e47 /gnu
parentf4442721ebd9a40d69b109944e821737edb8b027 (diff)
downloadguix-d1f1947a462eac5eef01fb1787fa22d1c801ced8.tar
guix-d1f1947a462eac5eef01fb1787fa22d1c801ced8.tar.gz
gnu: Add r-rlecuyer.
* gnu/packages/cran.scm (r-rlecuyer): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index da9482b1c0..3108169756 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -26802,6 +26802,28 @@ Yue-Pilon's (Yue, 2002) pre-whitening approaches to determining trends in
climate data.")
(license license:lgpl2.1)))
+(define-public r-rlecuyer
+ (package
+ (name "r-rlecuyer")
+ (version "0.3-5")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "rlecuyer" version))
+ (sha256
+ (base32
+ "09mniai7v8gapr6hd3zm8sm3vi1zcyhgym389904ykb2yx7l68s7"))))
+ (properties `((upstream-name . "rlecuyer")))
+ (build-system r-build-system)
+ (home-page
+ "https://www.iro.umontreal.ca/~lecuyer/myftp/papers/streams00.pdf")
+ (synopsis "R interface to RNG with multiple streams")
+ (description
+ "This package provides an interface to the C implementation of the random
+number generator with multiple independent streams developed by L'Ecuyer et
+al (2002). The main purpose of this package is to enable the use of this
+random number generator in parallel R applications.")
+ (license license:gpl2+)))
+
(define-public r-rlinsolve
(package
(name "r-rlinsolve")