aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2014-04-03 15:47:09 -0500
committerEric Bavier <bavier@member.fsf.org>2014-04-03 15:52:23 -0500
commitbb184d9884891ad190f2ebc4ffb71d6f361ab488 (patch)
tree3bd639a44c297abfc2c2df4d83398d700a34e582 /gnu
parent6e407e44a2011a59af03b2044068a66a6d792d5a (diff)
downloadguix-bb184d9884891ad190f2ebc4ffb71d6f361ab488.tar
guix-bb184d9884891ad190f2ebc4ffb71d6f361ab488.tar.gz
gnu: python: Use /nix/.../sh in popen2 module
* gnu/packages/python.scm (python-2): patch Lib/popen2.py to use /nix/.../sh.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 6b4d450599..bc56d7a2da 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -142,9 +142,13 @@
(alist-cons-before
'configure 'patch-lib-shells
(lambda _
- (substitute* '("Lib/subprocess.py"
- "Lib/distutils/tests/test_spawn.py"
- "Lib/test/test_subprocess.py")
+ ;; Filter for existing files, since some may not exist in all
+ ;; versions of python that are built with this recipe.
+ (substitute* (filter file-exists?
+ '("Lib/subprocess.py"
+ "Lib/popen2.py"
+ "Lib/distutils/tests/test_spawn.py"
+ "Lib/test/test_subprocess.py"))
(("/bin/sh") (which "sh"))))
(alist-cons-before
'check 'pre-check