aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-01-19 06:07:14 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-01-19 13:19:32 +0100
commitb7cbcee552c5bd4e8398fc70a3a45eaa002b2770 (patch)
tree2ed4826d5177e44c2bbf83001120ae58dd9ec2de /gnu
parenta040db6d70d021d482a12aa9a91ab4199a99d9af (diff)
downloadguix-b7cbcee552c5bd4e8398fc70a3a45eaa002b2770.tar
guix-b7cbcee552c5bd4e8398fc70a3a45eaa002b2770.tar.gz
gnu: minixml: Update to 2.11.
* gnu/packages/xml.scm (minixml): Update to 2.11. [source]: Use URL-FETCH/TARBOMB method. [arguments]: Add ‘fix-permissions’ phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xml.scm20
1 files changed, 15 insertions, 5 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index ff26214276..eccef0d898 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -973,18 +973,28 @@ Libxml2).")
(define-public minixml
(package
(name "minixml")
- (version "2.10")
+ (version "2.11")
(source (origin
- (method url-fetch)
+ (method url-fetch/tarbomb)
(uri (string-append "https://github.com/michaelrsweet/mxml/"
- "releases/download/release-" version
+ "releases/download/v" version
"/mxml-" version ".tar.gz"))
(sha256
(base32
- "14bqfq4lymhb31snz6wsvzhlavy0573v1nki1lbngiyxcj5zazr6"))))
+ "13xsw8vvkxd10vca42ccdyl9rs64lcvhbfz57aknpl3xcfn8mxma"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f)) ;no "check" target
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-permissions
+ ;; FIXME: url-fetch/tarbomb resets all permissions to 555/444.
+ (lambda _
+ (for-each
+ (lambda (file)
+ (chmod file #o644))
+ (find-files "doc" "\\."))
+ #t)))
+ #:tests? #f)) ; tests are run during build
(home-page "https://michaelrsweet.github.io/mxml")
(synopsis "Small XML parsing library")
(description