aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-04-04 22:04:00 +0200
committerLudovic Courtès <ludo@gnu.org>2014-04-04 22:04:44 +0200
commitaaff68eed37cd619863eafa2828328b8d1738f29 (patch)
tree0aa8796724c0e547c05c9d2828f64e85486cc6c3 /gnu
parent9c333da6f1b465e70767254ab19d9ec27681bb7b (diff)
downloadguix-aaff68eed37cd619863eafa2828328b8d1738f29.tar
guix-aaff68eed37cd619863eafa2828328b8d1738f29.tar.gz
gnu: shadow: Take the source from Git.
* gnu/packages/admin.scm (shadow)[source]: Use the git repo.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/admin.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 89df1a9148..0d50c1b9ca 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -22,6 +22,7 @@
#:use-module (guix licenses)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix build-system trivial)
@@ -164,13 +165,15 @@ client and server, a telnet client and server, and an rsh client and server.")
(name "shadow")
(version "4.1.5.1")
(source (origin
- (method url-fetch)
- (uri (string-append
- "http://pkg-shadow.alioth.debian.org/releases/shadow-"
- version ".tar.bz2"))
+ ;; Shadow has no real upstream, and not even tarballs.
+ ;; See <https://lists.gnu.org/archive/html/guix-devel/2014-03/msg00233.html>.
+ (method git-fetch)
+ (uri (git-reference
+ (url "git://git.debian.org/git/pkg-shadow/shadow")
+ (commit (string-append "upstream/" version))))
(sha256
(base32
- "1yvqx57vzih0jdy3grir8vfbkxp0cl0myql37bnmi2yn90vk6cma"))))
+ "1xx85d83kmacmjzqbamgydcjkwsqd5fi1s2wgwx6myq5wa39qx0n"))))
(build-system gnu-build-system)
(arguments
'(;; Assume System V `setpgrp (void)', which is the default on GNU