aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRaphaël Mélotte <raphael.melotte@mind.be>2020-12-28 17:58:38 +0100
committerLudovic Courtès <ludo@gnu.org>2021-01-13 16:26:59 +0100
commit7c430e8763189f1bd8c6e0b3acc4bcc542f6513b (patch)
tree7a91129f033dc13acb79b14acf521a66142e7c98 /gnu
parent5cdae34774c6054b80ff4ea4e42fa7d564a6d660 (diff)
downloadguix-7c430e8763189f1bd8c6e0b3acc4bcc542f6513b.tar
guix-7c430e8763189f1bd8c6e0b3acc4bcc542f6513b.tar.gz
gnu: Add emacs-helm-slack.
* gnu/packages/emacs-xyz.scm (emacs-helm-slack): New variable. Signed-off-by: Raphaël Mélotte <raphael.melotte@mind.be> Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1222e591c1..572b1af693 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -13748,6 +13748,36 @@ through them using @key{C-c C-SPC}.")
messaging service.")
(license license:gpl3+))))
+(define-public emacs-helm-slack
+ (let ((commit "465f6220f3f5bee4d95492991fca1290c89534eb")
+ (revision "1"))
+ (package
+ (name "emacs-helm-slack")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/yuya373/helm-slack")
+ (commit commit)))
+ (file-name (git-file-name name commit))
+ (sha256
+ (base32
+ "0p1s1kl8v68qjprqkf034cz911qzbqxbscqgpn0c3mbm3yfx81f7"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; HOME needs to exist for source compilation.
+ (add-before 'build 'set-HOME
+ (lambda _ (setenv "HOME" "/tmp") #t)))))
+ (propagated-inputs `(("emacs-slack", emacs-slack)))
+ (home-page "https://github.com/yuya373/helm-slack")
+ (synopsis "Helm extension for emacs-slack")
+ (description "This package provides an helm extension for emacs-slack
+Slack client.")
+ (license license:gpl3+))))
+
+
(define-public emacs-bash-completion
(package
(name "emacs-bash-completion")