aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorCarlo Zancanaro <carlo@zancanaro.id.au>2021-06-23 15:57:40 +1000
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-06-23 09:08:41 +0200
commit6b83da96162fe212a4e306b259c2c52f17878ec5 (patch)
tree42098e66df71ca1eefebd4653c89aba958fa2000 /gnu
parent5ab7fbad27c652bb2a7143995970e8b5886a0cb6 (diff)
downloadguix-6b83da96162fe212a4e306b259c2c52f17878ec5.tar
guix-6b83da96162fe212a4e306b259c2c52f17878ec5.tar.gz
gnu: Fix references to emacs-build-system's expand-load-path phase.
* gnu/packages/emacs-xyz.scm (emacs-pdf-tools)[#:phases]: Use emacs-expand-load-path instead of emacs-add-source-to-load-path. * gnu/packages/erlang.scm (emacs-erlang)[#:phases]: Use expand-load-path instead of add-source-to-load-path. * gnu/packages/protobuf.scm (emacs-protobuf-mode)[#:phases]: Use expand-load-path instead of add-source-to-load-path. Signed-off-by: Leo Prikler <leo.prikler@student.tugraz.at>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm2
-rw-r--r--gnu/packages/erlang.scm2
-rw-r--r--gnu/packages/protobuf.scm2
3 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index eef33fd437..28b87d49dd 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3310,7 +3310,7 @@ during idle time, while Emacs is doing nothing else.")
("pdf-tools-handle-upgrades" '()))))
(add-after 'emacs-patch-variables 'emacs-expand-load-path
(assoc-ref emacs:%standard-phases 'expand-load-path))
- (add-after 'emacs-add-source-to-load-path 'emacs-install
+ (add-after 'emacs-expand-load-path 'emacs-install
(assoc-ref emacs:%standard-phases 'install))
(add-after 'emacs-install 'emacs-build
(assoc-ref emacs:%standard-phases 'build))
diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index 7b5dc70b5d..d52d5c3983 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -232,7 +232,7 @@ built-in support for concurrency, distribution and fault tolerance.")
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-before 'add-source-to-load-path 'change-working-directory
+ (add-before 'expand-load-path 'change-working-directory
(lambda _ (chdir "lib/tools/emacs") #t)))))
(home-page "https://www.erlang.org/")
(synopsis "Erlang major mode for Emacs")
diff --git a/gnu/packages/protobuf.scm b/gnu/packages/protobuf.scm
index 857adf1703..9c6dcb51cc 100644
--- a/gnu/packages/protobuf.scm
+++ b/gnu/packages/protobuf.scm
@@ -311,7 +311,7 @@ structured data.")
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-before 'add-source-to-load-path 'change-working-directory
+ (add-before 'expand-load-path 'change-working-directory
(lambda _ (chdir "editors") #t)))))
(home-page "https://github.com/protocolbuffers/protobuf")
(synopsis "Protocol buffers major mode for Emacs")