aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-11-16 12:34:53 +0800
committer宋文武 <iyzsong@gmail.com>2015-11-18 09:16:31 +0800
commit4d62a9d304e17fa4793d557f6e065a0998e56e70 (patch)
tree491ae32bf3d207366be1c48d3e9fb32711f678b7 /gnu
parentba5dd1055fc97d96eb4c08ebfd61a7140ae7a94e (diff)
downloadguix-4d62a9d304e17fa4793d557f6e065a0998e56e70.tar
guix-4d62a9d304e17fa4793d557f6e065a0998e56e70.tar.gz
gnu: Add network-manager-applet.
* gnu/packages/gnome.scm (network-manager-applet): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d699806a38..0bd4c4e9b6 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4189,3 +4189,38 @@ available. It manages ethernet, WiFi, mobile broadband (WWAN), and PPPoE
devices, and provides VPN integration with a variety of different VPN
services.")
(license license:gpl2+)))
+
+(define-public network-manager-applet
+ (package
+ (name "network-manager-applet")
+ (version "1.0.6")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1yj0m6fb9v12d0di0rfmk3hx1vmygjkiff2c476rf792sbh56kax"))))
+ (build-system glib-or-gtk-build-system)
+ (arguments '(#:configure-flags '("--disable-migration")))
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("gobject-introspection" ,gobject-introspection)
+ ("pkg-config" ,pkg-config)))
+ (propagated-inputs
+ ;; libnm-gtk.pc refers to all these.
+ `(("dbus-glib" ,dbus-glib)
+ ("gtk+" ,gtk+)
+ ("network-manager" ,network-manager)))
+ (inputs
+ `(("iso-codes" ,iso-codes)
+ ("libgudev" ,libgudev)
+ ("libnotify" ,libnotify)
+ ("libsecret" ,libsecret)))
+ (synopsis "Applet for managing network connections")
+ (home-page "http://www.gnome.org/projects/NetworkManager/")
+ (description
+ "This package contains a systray applet for NetworkManager. It displays
+the available networks and allows users to easily switch between them.")
+ (license license:gpl2+)))