aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-03-31 12:35:09 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-03-31 20:00:21 +0200
commit32f77c0445b811481e011674ba6cfdfb22ead3c1 (patch)
tree1dc46f131186c750e885f7154bf2315c13bb149e /gnu
parent3cff95cbee7525a99347e3a3e9f2a9cebe55086e (diff)
downloadguix-32f77c0445b811481e011674ba6cfdfb22ead3c1.tar
guix-32f77c0445b811481e011674ba6cfdfb22ead3c1.tar.gz
gnu: Add python-networkx.
* gnu/packages/python.scm (python-networkx, python2-networkx): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index f7eb478c3c..c5cae6de45 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3335,6 +3335,35 @@ interfaces in an easy and portable manner.")
(define-public python2-netifaces
(package-with-python2 python-netifaces))
+(define-public python-networkx
+ (package
+ (name "python-networkx")
+ (version "1.9.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/n/networkx/networkx-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0n8wy0yq1kmdq4wh68mlhwhkndvwzx48lg41a1z0sxxms0wfp033"))))
+ (build-system python-build-system)
+ ;; python-decorator is needed at runtime
+ (propagated-inputs
+ `(("python-decorator" ,python-decorator)))
+ (native-inputs
+ `(("python-setuptools" ,python-setuptools)
+ ("python-nose" ,python-nose)))
+ (home-page "http://networkx.github.io/")
+ (synopsis "Python module for creating and manipulating graphs and networks")
+ (description
+ "NetworkX is a Python package for the creation, manipulation, and study
+of the structure, dynamics, and functions of complex networks.")
+ (license bsd-3)))
+
+(define-public python2-networkx
+ (package-with-python2 python-networkx))
+
(define-public snakemake
(package
(name "snakemake")