aboutsummaryrefslogtreecommitdiff
path: root/gnu/system
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>2022-06-17 23:18:35 -0600
committerMathieu Othacehe <othacehe@gnu.org>2022-06-24 10:21:06 +0200
commit62c86c8391ceb8953ca972498fd75ea9298b85ff (patch)
treef4ddcdf3749219c0fd36b92d0c2ba52b73566a07 /gnu/system
parent242fad357e969da3b1f80b7e4360b54d99ee03f3 (diff)
downloadguix-62c86c8391ceb8953ca972498fd75ea9298b85ff.tar
guix-62c86c8391ceb8953ca972498fd75ea9298b85ff.tar.gz
image: Add support for 32bit UEFI.
* gnu/bootloader/grub.scm (grub-efi32-bootloader): New variable. (install-grub-efi32): New variable. * gnu/build/bootloader.scm (install-efi): Add a 'targets' keyword argument. (install-efi-loader): Likewise. * gnu/build/image.scm (initialize-efi32-partition): New procedure. * gnu/packages/bootloaders.scm (grub-efi32): New variable. * gnu/system/image.scm (esp32-partition): New variable (efi32-disk-image): New variable. (efi32-raw-image-type): New variable. (system-disk-image)[partition-image]: Set '#:grub-efi32' when calling the partition initializer. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/system')
-rw-r--r--gnu/system/image.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/system/image.scm b/gnu/system/image.scm
index f02f6e0b8c..5972a944d7 100644
--- a/gnu/system/image.scm
+++ b/gnu/system/image.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2020, 2021 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2022 Pavel Shlyak <p.shlyak@pantherx.org>
+;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -66,6 +67,7 @@
root-label
esp-partition
+ esp32-partition
root-partition
efi-disk-image
@@ -75,6 +77,7 @@
image-with-os
efi-raw-image-type
+ efi32-raw-image-type
qcow2-image-type
iso-image-type
uncompressed-iso-image-type
@@ -110,6 +113,11 @@
(flags '(esp))
(initializer (gexp initialize-efi-partition))))
+(define esp32-partition
+ (partition
+ (inherit esp-partition)
+ (initializer (gexp initialize-efi32-partition))))
+
(define root-partition
(partition
(size 'guess)
@@ -123,6 +131,11 @@
(format 'disk-image)
(partitions (list esp-partition root-partition))))
+(define efi32-disk-image
+ (image
+ (format 'disk-image)
+ (partitions (list esp32-partition root-partition))))
+
(define iso9660-image
(image
(format 'iso9660)
@@ -164,6 +177,11 @@ set to the given OS."
(name 'efi-raw)
(constructor (cut image-with-os efi-disk-image <>))))
+(define efi32-raw-image-type
+ (image-type
+ (name 'efi32-raw)
+ (constructor (cut image-with-os efi32-disk-image <>))))
+
(define qcow2-image-type
(image-type
(name 'qcow2)
@@ -376,6 +394,7 @@ used in the image."
#$(image-shared-store? image))
#:system-directory #$os
#:grub-efi #+grub-efi
+ #:grub-efi32 #+grub-efi32
#:bootloader-package
#+(bootloader-package bootloader)
#:bootloader-installer