aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-09-28 13:57:21 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 22:28:59 +0100
commit5c31f4aa7c11fcf720c0ce0e26d55788e2df1044 (patch)
treeedfc0e7f53c478a9c15f4f1c15e24c2a10cdd194 /gnu/packages
parent00e10c6e674f0f292d5821bc4a513d48f4d1d164 (diff)
downloadguix-5c31f4aa7c11fcf720c0ce0e26d55788e2df1044.tar
guix-5c31f4aa7c11fcf720c0ce0e26d55788e2df1044.tar.gz
gnu: Remove python-setuptools and python2-setuptools from inputs (part 4a)
This patch contains the changes for all modules beside python.scm where setuptools are used in an inherited package and removing this input also removes the need for inheriting the package. This is the case if adding setuptools in the inherited package was the only change. Change this to not inherit and remove the new needless call to "strip-python2-variant (if applicable). * gnu/packages/bioinformatics.scm (python-biopython, python2-biopython, python-twobitreader, python2-twobitreader, python-plastid, python2-plastid, python2-pybigwig, python2-screed, sra-tools): No longer "inherit" Python 2 packages inheriting from a Python 3 package if the sole reason for inheriting was adding python-setuptools respective python2-setuptools to [inputs], [native-inputs] or [propagated-inputs]. Remove now needless [properties] "python2-variant" where applicable. * gnu/packages/django.scm (python-pytest-django, python2-pytest-django, python-django-filter, python2-django-filter): Likewise. * gnu/packages/gnupg.scm (python2-pygpgme): Likewise. * gnu/packages/mail.scm (python-mailmanclient, python2-mailmanclient): Likewise. * gnu/packages/mpd.scm (python-msp, python2-mpd2): Likewise. * gnu/packages/music.scm (python-pylast, python2-pylast): Likewise. * gnu/packages/openstack.scm (python-requests-mock, python2-requests-mock, python2-git-review): Likewise. * gnu/packages/password-utils.scm (python2-bcrypt): Likewise. * gnu/packages/protobuf.scm (python-protobuf, python2-protobuf): Likewise. * gnu/packages/statistics.scm (python-patsy, python2-patsy): Likewise. * gnu/packages/web.scm (python2-feedparser): Likewise.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioinformatics.scm35
-rw-r--r--gnu/packages/django.scm16
-rw-r--r--gnu/packages/gnupg.scm7
-rw-r--r--gnu/packages/mail.scm7
-rw-r--r--gnu/packages/mpd.scm9
-rw-r--r--gnu/packages/music.scm10
-rw-r--r--gnu/packages/openstack.scm16
-rw-r--r--gnu/packages/password-utils.scm6
-rw-r--r--gnu/packages/protobuf.scm7
-rw-r--r--gnu/packages/statistics.scm9
-rw-r--r--gnu/packages/web.scm6
11 files changed, 23 insertions, 105 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index a552686328..481a2a3bcb 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -680,15 +680,10 @@ bioinformatics programs; a standard sequence class and tools for performing
common operations on them; code to perform data classification; code for
dealing with alignments; code making it easy to split up parallelizable tasks
into separate processes; and more.")
- (license (license:non-copyleft "http://www.biopython.org/DIST/LICENSE"))
- (properties `((python2-variant . ,(delay python2-biopython))))))
+ (license (license:non-copyleft "http://www.biopython.org/DIST/LICENSE"))))
(define-public python2-biopython
- (let ((base (package-with-python2 (strip-python2-variant python-biopython))))
- (package
- (inherit base)
- (native-inputs `(("python2-setuptools" ,python2-setuptools)
- ,@(package-native-inputs base))))))
+ (package-with-python2 python-biopython))
;; An outdated version of biopython is required for seqmagick, see
;; https://github.com/fhcrc/seqmagick/issues/59
@@ -1427,7 +1422,6 @@ also includes an interface for tabix.")
(sha256
(base32
"1q8wnj2kga9nz1lwc4w7qv52smfm536hp6mc8w6s53lhyj0mpi22"))))
- (properties `((python2-variant . ,(delay python2-twobitreader))))
(build-system python-build-system)
(arguments
'(;; Tests are not distributed in the PyPi release.
@@ -1444,11 +1438,7 @@ UCSC genome browser.")
(license license:artistic2.0)))
(define-public python2-twobitreader
- (let ((base (package-with-python2 (strip-python2-variant python-twobitreader))))
- (package
- (inherit base)
- (native-inputs `(("python2-setuptools" ,python2-setuptools)
- ,@(package-native-inputs base))))))
+ (package-with-python2 python-twobitreader))
(define-public python-plastid
(package
@@ -1460,7 +1450,6 @@ UCSC genome browser.")
(sha256
(base32
"1sqkz5d3b9kf688mp7k771c87ins42j7j0whmkb49cb3fsg8s8lj"))))
- (properties `((python2-variant . ,(delay python2-plastid))))
(build-system python-build-system)
(arguments
;; Some test files are not included.
@@ -1485,12 +1474,7 @@ high-throughput sequencing data – with an emphasis on simplicity.")
(license license:bsd-3)))
(define-public python2-plastid
- (let ((base (package-with-python2 (strip-python2-variant python-plastid))))
- (package
- (inherit base)
- ;; setuptools is required at runtime
- (propagated-inputs `(("python2-setuptools" ,python2-setuptools)
- ,@(package-propagated-inputs base))))))
+ (package-with-python2 python-plastid))
(define-public cd-hit
(package
@@ -1939,10 +1923,7 @@ accessing bigWig files.")
(license license:expat)))
(define-public python2-pybigwig
- (let ((pybigwig (package-with-python2 python-pybigwig)))
- (package (inherit pybigwig)
- (native-inputs
- `(("python-setuptools" ,python2-setuptools))))))
+ (package-with-python2 python-pybigwig))
(define-public python-dendropy
(package
@@ -4568,11 +4549,7 @@ sequence itself can be retrieved from these databases.")
(license license:bsd-3)))
(define-public python2-screed
- (let ((base (package-with-python2 (strip-python2-variant python-screed))))
- (package
- (inherit base)
- (native-inputs `(("python2-setuptools" ,python2-setuptools)
- ,@(package-native-inputs base))))))
+ (package-with-python2 python-screed))
(define-public sra-tools
(package
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 1ab2094dce..804f681e59 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -148,16 +148,10 @@ with arguments to the field constructor.")
(synopsis "Django plugin for py.test")
(description "Pytest-django is a plugin for py.test that provides a set of
useful tools for testing Django applications and projects.")
- (properties `((python2-variant . ,(delay python2-pytest-django))))
(license license:bsd-3)))
(define-public python2-pytest-django
- (let ((base (package-with-python2
- (strip-python2-variant python-pytest-django))))
- (package (inherit base)
- (native-inputs
- `(("python2-setuptools" ,python2-setuptools)
- ,@(package-native-inputs base))))))
+ (package-with-python2 python-pytest-django))
(define-public python-django-filter
(package
@@ -180,13 +174,7 @@ useful tools for testing Django applications and projects.")
some of the more mundane bits of view code. Specifically, it allows users to
filter down a queryset based on a model’s fields, displaying the form to let
them do this.")
- (properties `((python2-variant . ,(delay python2-django-filter))))
(license license:bsd-3)))
(define-public python2-django-filter
- (let ((base (package-with-python2
- (strip-python2-variant python-django-filter))))
- (package (inherit base)
- (native-inputs
- `(("python2-setuptools" ,python2-setuptools)
- ,@(package-native-inputs base))))))
+ (package-with-python2 python-django-filter))
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 82932489de..b160d04ff7 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -417,12 +417,7 @@ decrypt messages using the OpenPGP format by making use of GPGME.")
(license license:lgpl2.1+)))
(define-public python2-pygpgme
- (let ((base (package-with-python2 python-pygpgme)))
- (package
- (inherit base)
- (native-inputs
- `(("python2-setuptools" ,python2-setuptools)
- ,@(package-native-inputs base))))))
+ (package-with-python2 python-pygpgme))
(define-public python-gnupg
(package
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index a152d50c36..b44555c04d 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1741,12 +1741,7 @@ for OpenSMTPD to extend its functionality.")
(description
"The mailmanclient library provides official Python bindings for
the GNU Mailman 3 REST API.")
- (properties `((python2-variant . ,(delay python2-mailmanclient))))
(license lgpl3+)))
(define-public python2-mailmanclient
- (let ((base (package-with-python2
- (strip-python2-variant python-mailmanclient))))
- (package (inherit base)
- (native-inputs
- `(("python2-setuptools" ,python2-setuptools))))))
+ (package-with-python2 python-mailmanclient))
diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
index ec0861db11..83d99778ed 100644
--- a/gnu/packages/mpd.scm
+++ b/gnu/packages/mpd.scm
@@ -257,15 +257,10 @@ information about tracks being played to a scrobbler, such as Libre.FM.")
(synopsis "Python MPD client library")
(description "Python-mpd2 is a Python library which provides a client
interface for the Music Player Daemon.")
- (license license:lgpl3+)
- (properties `((python2-variant . ,(delay python2-mpd2))))))
+ (license license:lgpl3+)))
(define-public python2-mpd2
- (let ((mpd2 (package-with-python2
- (strip-python2-variant python-mpd2))))
- (package (inherit mpd2)
- (native-inputs `(("python2-setuptools" ,python2-setuptools)
- ,@(package-native-inputs mpd2))))))
+ (package-with-python2 python-mpd2))
(define-public sonata
(package
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index d25c9c419a..61bcd3785b 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1829,16 +1829,10 @@ detailed track info including timbre, pitch, rhythm and loudness information.
(synopsis "Python interface to Last.fm and Libre.fm")
(description "A Python interface to Last.fm and other API-compatible
websites such as Libre.fm.")
- (license license:asl2.0)
- (properties `((python2-variant . ,(delay python2-pylast))))))
+ (license license:asl2.0)))
(define-public python2-pylast
- (let ((pylast (package-with-python2
- (strip-python2-variant python-pylast))))
- (package (inherit pylast)
- (native-inputs
- `(("python2-setuptools" ,python2-setuptools)
- ,@(package-native-inputs pylast))))))
+ (package-with-python2 python-pylast))
(define-public beets
(package
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index 930ce9eceb..8cf3b957a7 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -261,16 +261,10 @@ tested on Python version 3.2, 2.7 and 2.6.")
(description
"This module provides a building block to stub out the HTTP requests
portions of your testing code.")
- (license asl2.0)
- (properties `((python2-variant . ,(delay python2-requests-mock))))))
+ (license asl2.0)))
(define-public python2-requests-mock
- (let ((base (package-with-python2
- (strip-python2-variant python-requests-mock))))
- (package (inherit base)
- (native-inputs
- `(("python2-setuptools" ,python2-setuptools)
- ,@(package-native-inputs base))))))
+ (package-with-python2 python-requests-mock))
(define-public python-stevedore
(package
@@ -808,8 +802,4 @@ Gerrit for review, or fetching existing ones.")
(license asl2.0)))
(define-public python2-git-review
- (let ((base (package-with-python2 (strip-python2-variant python-git-review))))
- (package (inherit base)
- (native-inputs
- `(("python2-setuptools" ,python2-setuptools)
- ,@(package-native-inputs base))))))
+ (package-with-python2 python-git-review))
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index d6bc00c8f2..2e3c3b0632 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -375,8 +375,4 @@ Password Scheme\"} by Niels Provos and David Mazieres.")
(license license:asl2.0)))
(define-public python2-bcrypt
- (let ((bcrypt (package-with-python2 python-bcrypt)))
- (package (inherit bcrypt)
- (native-inputs
- `(("python2-setuptools" ,python2-setuptools)
- ,@(package-native-inputs bcrypt))))))
+ (package-with-python2 python-bcrypt))
diff --git a/gnu/packages/protobuf.scm b/gnu/packages/protobuf.scm
index 586e532746..f4e9e88233 100644
--- a/gnu/packages/protobuf.scm
+++ b/gnu/packages/protobuf.scm
@@ -70,10 +70,7 @@ internal RPC protocols and file formats.")
(description
"Protocol buffers are a language-neutral, platform-neutral extensible
mechanism for serializing structured data.")
- (license bsd-3)
- (properties `((python2-variant . ,(delay python2-protobuf))))))
+ (license bsd-3)))
(define-public python2-protobuf
- (package (inherit (package-with-python2
- (strip-python2-variant python-protobuf)))
- (native-inputs `(("python2-setuptools" ,python2-setuptools)))))
+ (package-with-python2 python-protobuf))
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index a19d6000d4..950c3ec64f 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -1416,15 +1416,10 @@ building design matrices.")
;; The majority of the code is distributed under BSD-2. The module
;; patsy.compat contains code derived from the Python standard library,
;; and is covered by the PSFL.
- (license (list license:bsd-2 license:psfl))
- (properties `((python2-variant . ,(delay python2-patsy))))))
+ (license (list license:bsd-2 license:psfl))))
(define-public python2-patsy
- (let ((patsy (package-with-python2 (strip-python2-variant python-patsy))))
- (package (inherit patsy)
- (native-inputs
- `(("python2-setuptools" ,python2-setuptools)
- ,@(package-native-inputs patsy))))))
+ (package-with-python2 python-patsy))
(define-public python-statsmodels
(package
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 81f861a905..e0c09ed396 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -3172,11 +3172,7 @@ CDF, Atom 0.3, and Atom 1.0 feeds.")
l:freebsd-doc)))) ; documentation
(define-public python2-feedparser
- (let ((base (package-with-python2
- (strip-python2-variant python-feedparser))))
- (package (inherit base)
- (native-inputs
- `(("python2-setuptools" ,python2-setuptools))))))
+ (package-with-python2 python-feedparser))
(define-public r-httpuv
(package