aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-01-19 16:25:13 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-01-19 17:28:31 +0100
commit162a13740041f907f0ce5c2aa05b52b162b4e81a (patch)
tree33dc83f44d28063b4262e4f3477061407192c58e /gnu/packages
parent28f6f22912ccbdbd485888c59ea263b8581027db (diff)
downloadguix-162a13740041f907f0ce5c2aa05b52b162b4e81a.tar
guix-162a13740041f907f0ce5c2aa05b52b162b4e81a.tar.gz
gnu: Consistently Write ‘file system(s)’.
It is the GNU way. * doc/guix.texi (Build Systems, DNS Services): Write ‘file system(s)’. * gnu/build/vm.scm (create-ext-file-system, create-fat-file-system): Likewise. * gnu/packages/backup.scm (dirvish, rsnapshot)[description]: Likewise. * gnu/packages/check.scm (python-testpath)[description]: Likewise. * gnu/packages/disk.scm (pydf)[description]: Likewise. * gnu/packages/file-systems.scm (disorderfs)[synopsis, description]: Likewise. (glusterfs)[description]: Likewise. * gnu/packages/haskell.scm (ghc-directory, ghc-system-fileio-bootstrap) (ghc-system-fileio)[synopsis]: Likewise. (ghc-fsnotify)[description]: Likewise. * gnu/packages/linux.scm (proot)[description]: Likewise. (jmtpfs)[synopsis, description]: Likewise. * gnu/packages/mate.scm (caja, caja-extensions)[description]: Likewise. * gnu/packages/storage.scm (ceph)[description]: Likewise. * gnu/packages/sync.scm (lsyncd)[description]: Likewise. * gnu/packages/syncthing.scm (syncthing)[synopsis]: Likewise. (go-github-com-zillode-notify)[description]: Likewise. * gnu/services/nfs.scm (pipefs-service-type): Likewise. * guix/scripts/system.scm (perform-action): Likewise.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/backup.scm4
-rw-r--r--gnu/packages/check.scm2
-rw-r--r--gnu/packages/disk.scm2
-rw-r--r--gnu/packages/file-systems.scm8
-rw-r--r--gnu/packages/haskell.scm8
-rw-r--r--gnu/packages/linux.scm8
-rw-r--r--gnu/packages/mate.scm4
-rw-r--r--gnu/packages/storage.scm2
-rw-r--r--gnu/packages/sync.scm4
-rw-r--r--gnu/packages/syncthing.scm4
10 files changed, 23 insertions, 23 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 7302406c57..a494a04047 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -418,7 +418,7 @@ rdiff-backup is easy to use and settings have sensible defaults.")
("rsync" ,rsync)))
(home-page "http://rsnapshot.org")
(synopsis "Deduplicating snapshot backup utility based on rsync")
- (description "rsnapshot is a filesystem snapshot utility based on rsync.
+ (description "rsnapshot is a file system snapshot utility based on rsync.
rsnapshot makes it easy to make periodic snapshots of local machines, and
remote machines over SSH. To reduce the disk space required for each backup,
rsnapshot uses hard links to deduplicate identical files.")
@@ -811,7 +811,7 @@ any special software, on top of SSH.")
(synopsis "Fast, disk based, rotating network backup system")
(description
"With dirvish you can maintain a set of complete images of your
-filesystems with unattended creation and expiration. A dirvish backup vault
+file systems with unattended creation and expiration. A dirvish backup vault
is like a time machine for your data. ")
(license (license:fsf-free "file://COPYING"
"Open Software License 2.0"))))
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 50675cb854..1585948b33 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1040,7 +1040,7 @@ testing frameworks.")
(synopsis "Test utilities for code working with files and commands")
(description
"Testpath is a collection of utilities for Python code working with files
-and commands. It contains functions to check things on the filesystem, and
+and commands. It contains functions to check things on the file system, and
tools for mocking system commands and recording calls to those.")
(license license:expat)))
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index e4d70ff820..c01faf5069 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -371,7 +371,7 @@ permit managing file systems not included in libparted.")
(synopsis "Colourised @command{df} clone")
(description "All-singing, all-dancing, fully colourised @command{df} clone
written in Python. It displays the amount of disk space available on the
-mounted filesystems, using different colours for different types of file
+mounted file systems, using different colours for different types of file
systems. Output format is completely customizable.")
(license license:public-domain)))
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index 4a8058b520..1d73f4aef4 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -132,10 +132,10 @@ single file can be mounted.")
;; FIXME: Tests require 'run-parts' which is not in Guix yet.
#:tests? #f))
(home-page "https://github.com/ReproducibleBuilds/disorderfs")
- (synopsis "FUSE filesystem that introduces non-determinism")
+ (synopsis "FUSE file system that introduces non-determinism")
(description
- "An overlay FUSE filesystem that introduces non-determinism
-into filesystem metadata. For example, it can randomize the order
+ "An overlay FUSE file system that introduces non-determinism
+into file system metadata. For example, it can randomize the order
in which directory entries are read. This is useful for detecting
non-determinism in the build process.")
(license license:gpl3+)))
@@ -201,7 +201,7 @@ non-determinism in the build process.")
("zlib" ,zlib)))
(home-page "https://www.gluster.org")
(synopsis "Distributed file system")
- (description "GlusterFS is a distributed scalable network filesystem
+ (description "GlusterFS is a distributed scalable network file system
suitable for data-intensive tasks such as cloud storage and media streaming.
It allows rapid provisioning of additional storage based on your storage
consumption needs. It incorporates automatic failover as a primary feature.
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index e7ea2d8de1..21858e481c 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5942,7 +5942,7 @@ supported. A module of colour names (\"Data.Colour.Names\") is provided.")
"0zkqihmdfz7bzv3sxh1p9ijl4vra880kfy3qy9h96flq7d2if0f2"))))
(build-system haskell-build-system)
(home-page "http://hackage.haskell.org/package/directory")
- (synopsis "Platform-agnostic library for filesystem operations")
+ (synopsis "Platform-agnostic library for file system operations")
(description
"This library provides a basic set of operations for manipulating
files and directories in a portable way.")
@@ -6203,7 +6203,7 @@ increasing type safety.")
("ghc-text" ,ghc-text)
("ghc-temporary" ,ghc-temporary)))
(home-page "https://github.com/fpco/haskell-filesystem")
- (synopsis "Consistent filesystem interaction across GHC versions")
+ (synopsis "Consistent file system interaction across GHC versions")
(description
"This is a small wrapper around the directory, unix, and Win32 packages,
for use with system-filepath. It provides a consistent API to the various
@@ -6424,7 +6424,7 @@ increasing type safety.")
("ghc-chell" ,ghc-chell)
("ghc-temporary" ,ghc-temporary)))
(home-page "https://github.com/fpco/haskell-filesystem")
- (synopsis "Consistent filesystem interaction across GHC versions")
+ (synopsis "Consistent file system interaction across GHC versions")
(description
"This is a small wrapper around the directory, unix, and Win32 packages,
for use with system-filepath. It provides a consistent API to the various
@@ -6744,7 +6744,7 @@ accessed or modified.")
(synopsis "Cross platform library for file change notification.")
(description "Cross platform library for file creation, modification, and
deletion notification. This library builds upon existing libraries for platform
-specific Windows, Mac, and Linux filesystem event notification.")
+specific Windows, Mac, and Linux file system event notification.")
(license license:bsd-3)))
(define-public ghc-ieee754
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 13e08f2654..c097079382 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4304,7 +4304,7 @@ userspace queueing component and the logging subsystem.")
"PRoot is a user-space implementation of @code{chroot}, @code{mount --bind},
and @code{binfmt_misc}. This means that users don't need any privileges or
setup to do things like using an arbitrary directory as the new root
-filesystem, making files accessible somewhere else in the file system
+file system, making files accessible somewhere else in the file system
hierarchy, or executing programs built for another CPU architecture
transparently through QEMU user-mode. Also, developers can use PRoot as a
generic process instrumentation engine thanks to its extension mechanism.
@@ -4391,10 +4391,10 @@ NexGen, Rise, and SiS CPUs.")
(native-inputs
`(("pkg-config" ,pkg-config)))
(home-page "https://github.com/JasonFerrara/jmtpfs")
- (synopsis "Use a FUSE filesystem to access data over MTP")
- (description "jmtpfs uses FUSE (filesystem in userspace) to provide access
+ (synopsis "Use a FUSE file system to access data over MTP")
+ (description "jmtpfs uses FUSE (file system in userspace) to provide access
to data over the Media Transfer Protocol (MTP). Unprivileged users can mount
-the MTP device as a filesystem.")
+the MTP device as a file system.")
(license license:gpl3)))
(define-public procenv
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index 71f9589937..51111f44b8 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -842,7 +842,7 @@ infamous 'Wanda the Fish'.")
"Caja is the official file manager for the MATE desktop.
It allows for browsing directories, as well as previewing files and launching
applications associated with them. Caja is also responsible for handling the
-icons on the MATE desktop. It works on local and remote filesystems.")
+icons on the MATE desktop. It works on local and remote file systems.")
;; There is a note about a TRADEMARKS_NOTICE file in COPYING which
;; does not exist. It is safe to assume that this is of no concern
;; for us.
@@ -900,7 +900,7 @@ icons on the MATE desktop. It works on local and remote filesystems.")
"Caja is the official file manager for the MATE desktop.
It allows for browsing directories, as well as previewing files and launching
applications associated with them. Caja is also responsible for handling the
-icons on the MATE desktop. It works on local and remote filesystems.")
+icons on the MATE desktop. It works on local and remote file systems.")
(license license:gpl2+)))
(define-public mate-control-center
diff --git a/gnu/packages/storage.scm b/gnu/packages/storage.scm
index 1dca920a30..bee349f6f6 100644
--- a/gnu/packages/storage.scm
+++ b/gnu/packages/storage.scm
@@ -340,7 +340,7 @@
(description
"Ceph is a distributed storage system designed for reliability and
performance. It provides network-based block devices (RBD), a POSIX
-compliant filesystem (CephFS), and offers compatibility with various
+compliant file system (CephFS), and offers compatibility with various
storage protocols (S3, NFS, and others) through the RADOS gateway.")
;; The Ceph libraries are LGPL2.1 and most of the utilities fall under
;; GPL2. The installed erasure code plugins are BSD-3 licensed and do
diff --git a/gnu/packages/sync.scm b/gnu/packages/sync.scm
index 4ed62ff966..3656f5855e 100644
--- a/gnu/packages/sync.scm
+++ b/gnu/packages/sync.scm
@@ -204,6 +204,6 @@ interface (inotify or fsevents). It aggregates and combines events for a few
seconds and then spawns one (or more) process(es) to synchronize the changes.
By default this is rsync, which must be installed on all source and target
machines. Lsyncd is thus a light-weight live mirror solution that is
-comparatively easy to install not requiring new filesystems or block devices
-and does not hamper local filesystem performance.")
+comparatively easy to install not requiring new file systems or block devices
+and does not hamper local file system performance.")
(license license:gpl2+)))
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 66c3fedfe2..3fb70d13da 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -160,7 +160,7 @@
("go-github-com-zillode-notify" ,go-github-com-zillode-notify)
;; For tests
("go-github-com-d4l3k-messagediff" ,go-github-com-d4l3k-messagediff)))
- (synopsis "Decentralized continuous filesystem synchronization")
+ (synopsis "Decentralized continuous file system synchronization")
(description "Syncthing is a peer-to-peer file synchronization tool that
supports a wide variety of computing platforms. It uses the Block Exchange
Protocol.")
@@ -1873,7 +1873,7 @@ Authentication and Privacy Infrastructure).")
(propagated-inputs
`(("go-golang-org-x-sys-unix" ,go-golang-org-x-sys-unix)))
(synopsis "Filesystem event notification library")
- (description "This package provides @code{notify}, a filesystem event
+ (description "This package provides @code{notify}, a file system event
notification library in Go.")
(home-page "https://github.com/zillode/notify")
(license expat))))