aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-05-14 17:21:22 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-05-14 17:21:22 +0200
commitbdb8267680f14ee5d3df9d029f23279c1457c211 (patch)
tree14a94886ca06d6ae9ef80456163aa1a231ff090c /gnu/packages
parent3590a6b5cf4b46a76b69f3719740d6d5b8a04428 (diff)
parent28ee4d41edf072776777ff3f83aef8502df909e5 (diff)
downloadguix-bdb8267680f14ee5d3df9d029f23279c1457c211.tar
guix-bdb8267680f14ee5d3df9d029f23279c1457c211.tar.gz
Merge commit '28ee4d41edf072776777ff3f83aef8502df909e5' into staging
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/glib.scm8
-rw-r--r--gnu/packages/gnome.scm29
-rw-r--r--gnu/packages/gtk.scm8
3 files changed, 20 insertions, 25 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 6de9cce0b7..8c334c467d 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -67,7 +67,7 @@
(define dbus
(package
(name "dbus")
- (version "1.10.16")
+ (version "1.10.18")
(source (origin
(method url-fetch)
(uri (string-append
@@ -75,7 +75,7 @@
version ".tar.gz"))
(sha256
(base32
- "121kqkjsd3vgf8vca8364xl44qa5086h7qy5zs5f1l78ldpbmc57"))
+ "0jjirhw6xwz2ffmbg5kr79108l8i1bdaw7szc67n3qpkygaxsjb0"))
(patches (search-patches "dbus-helper-search-path.patch"))))
(build-system gnu-build-system)
(arguments
@@ -137,7 +137,7 @@ shared NFS home directories.")
(define glib
(package
(name "glib")
- (version "2.50.3")
+ (version "2.52.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/"
@@ -145,7 +145,7 @@ shared NFS home directories.")
name "-" version ".tar.xz"))
(sha256
(base32
- "16frrwhc1yqkzx6bgh3060g94dr2biab17fb01mrni819jzr9vl2"))
+ "0vsqrvjwsk2x3mm2i428hpm5vgsi1b384l6xdhm7xmzj2yw2d34l"))
(patches (search-patches "glib-tests-timer.patch"))))
(build-system gnu-build-system)
(outputs '("out" ; everything
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index be11442ede..0123fbd123 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -512,7 +512,7 @@ forgotten when the session ends.")
(define-public evince
(package
(name "evince")
- (version "3.22.1")
+ (version "3.24.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -520,15 +520,10 @@ forgotten when the session ends.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0713mcrym5ykhl5smqxi6m9578gz3nkibmkmc794amss7gdkkm7k"))))
+ "13yw0i68dgqp9alyliy3zifszh7rikkpi1xbz5binvxxgfpraf04"))))
(build-system glib-or-gtk-build-system)
(arguments
`(#:configure-flags '("--disable-nautilus")
-
- ;; FIXME: Tests fail with:
- ;; ImportError: No module named gi.repository
- ;; Where should that module come from?
- #:tests? #f
#:phases
(modify-phases %standard-phases
(add-before 'install 'skip-gtk-update-icon-cache
@@ -584,7 +579,7 @@ on the GNOME Desktop with a single simple application.")
(define-public gsettings-desktop-schemas
(package
(name "gsettings-desktop-schemas")
- (version "3.22.0")
+ (version "3.24.0")
(source
(origin
(method url-fetch)
@@ -593,7 +588,7 @@ on the GNOME Desktop with a single simple application.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1qgalzqwg0fl0n22vslqcsnsmj9kc54qj25ib16rxaf36jxcf1hg"))))
+ "145vpcljy4660cnk8zk91qf7ywa7hqfl5hhw025gy8hxcqzklmzn"))))
(build-system gnu-build-system)
(inputs
`(("glib" ,glib)))
@@ -2753,7 +2748,7 @@ services for numerous locations.")
(define-public gnome-settings-daemon
(package
(name "gnome-settings-daemon")
- (version "3.22.1")
+ (version "3.24.1")
(source
(origin
(method url-fetch)
@@ -2762,7 +2757,7 @@ services for numerous locations.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1finsr7yqvix6n3rdwclv4fpgagmz6xyrk3qzapkn9ljv76rfzdm"))))
+ "02vm0jwhs9rdi3dphxw7dxharx7ng0l12j6hfdmn3vjc7v3ds50v"))))
(build-system glib-or-gtk-build-system)
(arguments
`(;; Color management test can't reach the colord system service.
@@ -3513,7 +3508,7 @@ supports playlists, song ratings, and any codecs installed through gstreamer.")
(define-public eog
(package
(name "eog")
- (version "3.20.5")
+ (version "3.24.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -3521,7 +3516,7 @@ supports playlists, song ratings, and any codecs installed through gstreamer.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0fqvfc4y1lbv0awh8dbx9khfha0hdkmnj1lzw5jq0l7jmahwbrz6"))))
+ "1rr7zy8afqgl15j1zz8l37svyv6bw4r3l04yf70zlnf1w8bf27pm"))))
(build-system glib-or-gtk-build-system)
(arguments
`(#:phases
@@ -4051,7 +4046,7 @@ share them with others via social networking and more.")
(define-public file-roller
(package
(name "file-roller")
- (version "3.22.2")
+ (version "3.24.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -4059,7 +4054,7 @@ share them with others via social networking and more.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1yaxd0lqhajszilblkidqfkaffhzml10l7ib64023y36qgf8q597"))))
+ "0fkz9h9a6149crmf6311fsqlmv9wyrxk86470vxib941ppl4a581"))))
(build-system glib-or-gtk-build-system)
(arguments
'(#:phases
@@ -5282,7 +5277,7 @@ is complete it provides a graphical representation of each selected folder.")
(define-public gnome-backgrounds
(package
(name "gnome-backgrounds")
- (version "3.22.1")
+ (version "3.24.0")
(source
(origin
(method url-fetch)
@@ -5291,7 +5286,7 @@ is complete it provides a graphical representation of each selected folder.")
name "-" version ".tar.xz"))
(sha256
(base32
- "09gfdrm1kaz2knyghhjb0ka1kklgbcbnqgy4c90bg0v3n899ij5z"))))
+ "1jkikis9k3psp6rb8axnqy86awdyg5rzfbcp9gx40a99b4hlrnnb"))))
(build-system glib-or-gtk-build-system)
(native-inputs
`(("intltool" ,intltool)))
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index dffa2baf30..985056b95b 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -170,7 +170,7 @@ affine transformation (scale, rotation, shear, etc.).")
(define-public harfbuzz
(package
(name "harfbuzz")
- (version "1.4.3")
+ (version "1.4.6")
(source (origin
(method url-fetch)
(uri (string-append "https://www.freedesktop.org/software/"
@@ -178,7 +178,7 @@ affine transformation (scale, rotation, shear, etc.).")
version ".tar.bz2"))
(sha256
(base32
- "08akv3qzwnf48xajb60dfcchkmfdjkpp65a0xd8s98w81901g343"))))
+ "14yj514yfy373np3gxk930a443j1zgnwg6mm0kdzzjr0rn0qp9r1"))))
(build-system gnu-build-system)
(outputs '("out"
"bin")) ; 160K, only hb-view depend on cairo
@@ -508,7 +508,7 @@ in the GNOME project.")
(define-public at-spi2-core
(package
(name "at-spi2-core")
- (version "2.22.0")
+ (version "2.24.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -516,7 +516,7 @@ in the GNOME project.")
name "-" version ".tar.xz"))
(sha256
(base32
- "02n8ybhg8344mpjwvkhnzvr0qbvvl6ryi2q9irwhi0ri46ps6pj1"))))
+ "1kdgc5gkw3fsgxvwwsg7djvqijpc3xmpp9bp6k6v60yrzcag6yb1"))))
(build-system gnu-build-system)
(outputs '("out" "doc"))
(arguments