aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorKonrad Hinsen <konrad.hinsen@fastmail.net>2018-03-16 13:10:28 +0100
committerOleg Pykhalov <go.wigust@gmail.com>2018-03-16 17:04:14 +0300
commit5d818b3557cc3b546d5bd0639359c14c7c0ab685 (patch)
tree5ac946769c80683a2bcfa50aa331782a1b813406 /gnu/packages
parent22d628148ce857b620f5b8e48dc7cabe004313c5 (diff)
downloadguix-5d818b3557cc3b546d5bd0639359c14c7c0ab685.tar
guix-5d818b3557cc3b546d5bd0639359c14c7c0ab685.tar.gz
gnu: Add emacs-deft.
* gnu/packages/emacs.scm (emacs-deft): New variable. Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index fbdde863c7..a6c674dfb2 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -7386,3 +7386,23 @@ inherit a login shell's environment variables. It also allows other
environment variables to be retrieved from the shell, so that Emacs will see
the same values you get in a terminal.")
(license license:gpl3+)))
+
+(define-public emacs-deft
+ (package
+ (name "emacs-deft")
+ (version "0.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://stable.melpa.org/packages/deft-"
+ version ".el"))
+ (sha256
+ (base32
+ "1vb9cjxskc7c0yyf9pvxy1fzypg1vrcgwnjz0m3hslinsgdyig58"))))
+ (build-system emacs-build-system)
+ (home-page "https://jblevins.org/projects/deft/")
+ (synopsis "Quickly browse, filter, and edit plain text notes")
+ (description
+ "Deft is an Emacs mode for quickly browsing, filtering, and editing
+directories of plain text notes, inspired by Notational Velocity.")
+ (license license:bsd-3)))