aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-06-17 22:13:33 -0400
committerMark H Weaver <mhw@netris.org>2015-06-17 23:19:02 -0400
commit9ae1e920718e95577c12de890754b6a6a4ff70a1 (patch)
tree2b10dbbddcf67b0df411a48ce2ce4ecf2da2a9e2 /gnu/packages
parenta2ee6cbea281ac20fefe948459b85c26010ea578 (diff)
downloadguix-9ae1e920718e95577c12de890754b6a6a4ff70a1.tar
guix-9ae1e920718e95577c12de890754b6a6a4ff70a1.tar.gz
gnu: cpio: Fix symlink-bad-length test.
* gnu/packages/patches/cpio-fix-symlink-bad-length-test.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/cpio.scm (cpio): Add patch.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cpio.scm14
-rw-r--r--gnu/packages/patches/cpio-fix-symlink-bad-length-test.patch44
2 files changed, 52 insertions, 6 deletions
diff --git a/gnu/packages/cpio.scm b/gnu/packages/cpio.scm
index 87f85d00e8..cfb416239d 100644
--- a/gnu/packages/cpio.scm
+++ b/gnu/packages/cpio.scm
@@ -36,12 +36,14 @@
(sha256
(base32
"1gavgpzqwgkpagjxw72xgxz52y1ifgz0ckqh8g7cckz7jvyhp0mv"))
- (patches (list (search-patch "cpio-CVE-2014-9112-pt1.patch")
- (search-patch "cpio-CVE-2014-9112-pt2.patch")
- (search-patch "cpio-CVE-2014-9112-pt3.patch")
- (search-patch "cpio-CVE-2014-9112-pt4.patch")
- (search-patch "cpio-CVE-2014-9112-pt5.patch")
- (search-patch "cpio-gets-undeclared.patch")))))
+ (patches (map search-patch
+ '("cpio-CVE-2014-9112-pt1.patch"
+ "cpio-CVE-2014-9112-pt2.patch"
+ "cpio-CVE-2014-9112-pt3.patch"
+ "cpio-CVE-2014-9112-pt4.patch"
+ "cpio-CVE-2014-9112-pt5.patch"
+ "cpio-fix-symlink-bad-length-test.patch"
+ "cpio-gets-undeclared.patch")))))
(build-system gnu-build-system)
;; FIXME: autoconf is needed to run autom4te, to update to test suite
diff --git a/gnu/packages/patches/cpio-fix-symlink-bad-length-test.patch b/gnu/packages/patches/cpio-fix-symlink-bad-length-test.patch
new file mode 100644
index 0000000000..58a5a478c9
--- /dev/null
+++ b/gnu/packages/patches/cpio-fix-symlink-bad-length-test.patch
@@ -0,0 +1,44 @@
+From bebf9662c406d1d137a66c567d8748b489d352e7 Mon Sep 17 00:00:00 2001
+From: Pavel Raiskup <praiskup@redhat.com>
+Date: Thu, 4 Jun 2015 13:27:42 +0200
+Subject: [PATCH] tests: fix expected output for old file
+
+Thanks Victor Rodriguez. Upstream thread:
+http://lists.gnu.org/archive/html/bug-cpio/2015-06/msg00000.html
+
+* tests/symlink-bad-length.at (STDOUT): Expect the year string
+'2014' is printed and not time because the file in archive is
+older than 6 months.
+* Thanks: Mention Victor.
+---
+ THANKS | 1 +
+ tests/symlink-bad-length.at | 2 +-
+ 2 files changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/THANKS b/THANKS
+index 45b0dfb..3228df9 100644
+--- a/THANKS
++++ b/THANKS
+@@ -23,6 +23,7 @@ Mitsuru Chinen <mchinen@yamato.ibm.com>
+ Peter Breitenlohner <peb@mppmu.mpg.de>
+ Peter Vrabec <pvrabec@redhat.com>
+ Robert Millan <rmh@aybabtu.com>
++Victor Rodriguez <vm.rod25@gmail.com>
+
+ Local Variables:
+ mode: Fundamental
+diff --git a/tests/symlink-bad-length.at b/tests/symlink-bad-length.at
+index e1a7093..2cdc692 100644
+--- a/tests/symlink-bad-length.at
++++ b/tests/symlink-bad-length.at
+@@ -57,7 +57,7 @@ cat stderr | grep -v \
+ echo >&2 STDERR
+ ],
+ [0],
+-[-rw-rw-r-- 1 10029 10031 13 Nov 25 11:52 FILE
++[-rw-rw-r-- 1 10029 10031 13 Nov 25 2014 FILE
+ ],[STDERR
+ ])
+
+--
+2.1.0