aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2024-12-17 20:47:11 +0000
committerChristopher Baines <mail@cbaines.net>2024-12-17 20:47:11 +0000
commit8d06427af0fd70116ff2aea50a933203481e3d33 (patch)
treeb04e3968fafac6e3adb968b97cd495df8734386b /gnu/packages
parent2185b5ad3d252774ae633a90e03d34cc24b95c38 (diff)
downloadguix-8d06427af0fd70116ff2aea50a933203481e3d33.tar
guix-8d06427af0fd70116ff2aea50a933203481e3d33.tar.gz
gnu: python-django-filter: Update to 24.3.
* gnu/packages/django.scm (python-django-filter): Update to 24.3. Change-Id: If36ba37fc3b3913421f5f3e27c77da2d0c42b157
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/django.scm25
1 files changed, 14 insertions, 11 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 14e0dc64d9..f0770fef7f 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -522,23 +522,26 @@ your code.")
(define-public python-django-filter
(package
(name "python-django-filter")
- (version "2.3.0")
+ (version "24.3")
(source (origin
(method url-fetch)
- (uri (pypi-uri "django-filter" version))
+ (uri (pypi-uri "django_filter" version))
(sha256
(base32
- "1bz5qzdk9pk4a2lp2yacrdnqmkv24vxnz4k3lykrnpc3b7bkvrhi"))))
- (build-system python-build-system)
+ "1hyr5i5f4n5kk5ax3y39hslhy0wi2nqk6rrgajh1rlmg69kszk6q"))))
+ (build-system pyproject-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda _
- (invoke "python" "runtests.py"))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "python" "runtests.py"))))))
(native-inputs
- (list python-django python-django-rest-framework
- python-django-crispy-forms python-mock))
+ (list python-django-4.2
+ python-django-rest-framework
+ python-tzdata
+ python-flit-core))
(home-page "https://django-filter.readthedocs.io/en/latest/")
(synopsis "Reusable Django application to filter querysets dynamically")
(description