aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAlex Vong <alexvong1995@gmail.com>2016-10-29 18:10:00 +0800
committerRicardo Wurmus <rekado@elephly.net>2016-10-29 23:49:05 +0200
commitee5fb7ee5013a9033fc572d8c7cfec7047b58c33 (patch)
tree5721dd954d8f7984f57918610de533754e3f2f0b /gnu/packages
parent8f210c0e0e3386920aaf125371cb7aa1420f761f (diff)
downloadguix-ee5fb7ee5013a9033fc572d8c7cfec7047b58c33.tar
guix-ee5fb7ee5013a9033fc572d8c7cfec7047b58c33.tar.gz
gnu: Add python2-rpython.
* gnu/packages/python.scm (python2-rpython): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 45e683c009..f05690617a 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -29,6 +29,7 @@
;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2016 Stefan Reichoer <stefan@xsteve.at>
;;; Copyright © 2016 Dylan Jeffers <sapientech@sapientech@openmailbox.org>
+;;; Copyright © 2016 Alex Vong <alexvong1995@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3150,6 +3151,30 @@ writing C extensions for Python as easy as Python itself.")
(inputs
`(("python-2" ,python-2))))) ; this is not automatically changed
+;; The RPython toolchain currently does not support Python 3.
+(define-public python2-rpython
+ (package
+ (name "python2-rpython")
+ (version "0.1.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "rpython" version))
+ (sha256
+ (base32
+ "07pps06fq4c4wmi5ii0sgh9zgwniz5y7frqhm28g3a154l163fxc"))))
+ (build-system python-build-system)
+ (arguments `(#:python ,python-2))
+ (native-inputs
+ `(("python2-pytest" ,python2-pytest) ; needed for running tests
+ ("python2-setuptools" ,python2-setuptools)))
+ (home-page "https://rpython.readthedocs.org")
+ (synopsis "Framework for implementing interpreters and virtual machines")
+ (description "RPython is a translation and support framework for
+producing implementations of dynamic languages, emphasizing a clean separation
+between language specification and implementation aspects.")
+ (license license:expat)))
+
;; This version of numpy is missing the documentation and is only used to
;; build matplotlib which is required to build numpy's documentation.
(define python-numpy-bootstrap