aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-13 12:14:32 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-13 13:04:18 +0100
commitc80fb90f4a04deca33ef7e7b92d4678ca5ef93af (patch)
tree30cd308279d437598fb997d5083311e0febe70d8 /gnu/packages
parentd691e966579398d6dae7a7f50fbe5acd6041989d (diff)
downloadguix-c80fb90f4a04deca33ef7e7b92d4678ca5ef93af.tar
guix-c80fb90f4a04deca33ef7e7b92d4678ca5ef93af.tar.gz
gnu: r-vegan: Move from bioinformatics to cran.
* gnu/packages/bioinformatics.scm (r-vegan): Move from here... * gnu/packages/cran.scm (r-vegan): ...to here.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioinformatics.scm30
-rw-r--r--gnu/packages/cran.scm31
2 files changed, 31 insertions, 30 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 42f5c3b80d..66785d013a 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -6338,36 +6338,6 @@ between two different types of motif instances using as much relevant
information as possible.")
(license (list license:gpl2+ license:gpl3+))))
-(define-public r-vegan
- (package
- (name "r-vegan")
- (version "2.5-3")
- (source
- (origin
- (method url-fetch)
- (uri (cran-uri "vegan" version))
- (sha256
- (base32
- "023xznh0iy0496icpchadmp7a3rk3nj9s48fvwlvp3dssw58yp3c"))))
- (build-system r-build-system)
- (native-inputs
- `(("gfortran" ,gfortran)))
- (propagated-inputs
- `(("r-cluster" ,r-cluster)
- ("r-knitr" ,r-knitr) ; needed for vignettes
- ("r-lattice" ,r-lattice)
- ("r-mass" ,r-mass)
- ("r-mgcv" ,r-mgcv)
- ("r-permute" ,r-permute)))
- (home-page "https://cran.r-project.org/web/packages/vegan")
- (synopsis "Functions for community ecology")
- (description
- "The vegan package provides tools for descriptive community ecology. It
-has most basic functions of diversity analysis, community ordination and
-dissimilarity analysis. Most of its multivariate tools can be used for other
-data types as well.")
- (license license:gpl2+)))
-
(define-public r-annotate
(package
(name "r-annotate")
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 4ba6699ab8..1bd20b12d3 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015, 2016, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2016, 2017 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2017, 2018 Roel Janssen <roel@gnu.org>
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Raoul Bonnal <ilpuccio.febo@gmail.com>
@@ -82,6 +83,36 @@
the system clipboards.")
(license license:gpl3)))
+(define-public r-vegan
+ (package
+ (name "r-vegan")
+ (version "2.5-3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "vegan" version))
+ (sha256
+ (base32
+ "023xznh0iy0496icpchadmp7a3rk3nj9s48fvwlvp3dssw58yp3c"))))
+ (build-system r-build-system)
+ (native-inputs
+ `(("gfortran" ,gfortran)))
+ (propagated-inputs
+ `(("r-cluster" ,r-cluster)
+ ("r-knitr" ,r-knitr) ; needed for vignettes
+ ("r-lattice" ,r-lattice)
+ ("r-mass" ,r-mass)
+ ("r-mgcv" ,r-mgcv)
+ ("r-permute" ,r-permute)))
+ (home-page "https://cran.r-project.org/web/packages/vegan")
+ (synopsis "Functions for community ecology")
+ (description
+ "The vegan package provides tools for descriptive community ecology. It
+has most basic functions of diversity analysis, community ordination and
+dissimilarity analysis. Most of its multivariate tools can be used for other
+data types as well.")
+ (license license:gpl2+)))
+
(define-public r-tidyverse
(package
(name "r-tidyverse")