aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJohn Darrington <jmd@gnu.org>2017-03-08 19:24:31 +0100
committerJohn Darrington <jmd@gnu.org>2017-03-18 10:31:54 +0100
commit6d5f63b690586e819258617a8d0fb9bd18897b8f (patch)
tree72e81c7a7b61007267fdbf189fb3d4b1c41f8396 /gnu/packages
parenta53d6719bc6b6b4afdc58e257ac712df316c8858 (diff)
downloadguix-6d5f63b690586e819258617a8d0fb9bd18897b8f.tar
guix-6d5f63b690586e819258617a8d0fb9bd18897b8f.tar.gz
gnu: Add maxflow.
* gnu/packages/maths.scm (maxflow): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/maths.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index fe85983c24..ed13556cb4 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1138,6 +1138,30 @@ modules is done either interactively using the graphical user interface or in
ASCII text files using Gmsh's own scripting language.")
(license license:gpl2+)))
+(define-public maxflow
+ (package
+ (name "maxflow")
+ (version "3.04")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gerddie/maxflow.git")
+ (commit "42401fa54823d16b9da47716f04e5d9ef1605875")))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "0rll38whw55h0vcjrrwdnh9ascvxby0ph7n1l0d12z17cg215kkb"))))
+ (build-system cmake-build-system)
+ (home-page "http://pub.ist.ac.at/~vnk/software.html")
+ (synopsis "Library implementing Maxflow algorithm")
+ (description "An implementation of the maxflow algorithm described in
+@cite{An Experimental Comparison of Min-Cut/Max-Flow Algorithms for
+Energy Minimization in Computer Vision.\n
+Yuri Boykov and Vladimir Kolmogorov.\n
+In IEEE Transactions on Pattern Analysis and Machine Intelligence,\n
+September 2004}")
+ (license license:gpl3+)))
+
(define-public petsc
(package
(name "petsc")