aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorKei Kebreau <kei@openmailbox.org>2017-03-19 23:06:50 -0400
committerKei Kebreau <kei@openmailbox.org>2017-03-20 14:29:44 -0400
commit0b5d078f8ba7953a51343fde087e157fbc4a0308 (patch)
tree6e01ffb9f14a5aeb5298c0ce51f5ca1d2c1fa5c4 /gnu/packages
parent6f9ba4c91c096a2fb95da111be0657d99ef2b683 (diff)
downloadguix-0b5d078f8ba7953a51343fde087e157fbc4a0308.tar
guix-0b5d078f8ba7953a51343fde087e157fbc4a0308.tar.gz
gnu: Add freedoom.
* gnu/packages/games.scm (freedoom): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/games.scm72
1 files changed, 72 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index f264ef206f..a8fdd341c7 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -58,6 +58,7 @@
#:use-module (gnu packages audio)
#:use-module (gnu packages avahi)
#:use-module (gnu packages boost)
+ #:use-module (gnu packages documentation)
#:use-module (gnu packages fltk)
#:use-module (gnu packages fribidi)
#:use-module (gnu packages game-development)
@@ -69,6 +70,7 @@
#:use-module (gnu packages gperf)
#:use-module (gnu packages gtk)
#:use-module (gnu packages guile)
+ #:use-module (gnu packages imagemagick)
#:use-module (gnu packages libcanberra)
#:use-module (gnu packages libunwind)
#:use-module (gnu packages haskell)
@@ -113,6 +115,76 @@
#:use-module (guix build-system cmake)
#:use-module (guix build-system trivial))
+(define-public freedoom
+ (package
+ (name "freedoom")
+ (version "0.11.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/" name "/" name
+ "/archive/v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "060dqppd9fi079yw6c82klsjaslcabq6xan67wf9hs0cy39i0kpv"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:make-flags `(,(string-append "prefix=" (assoc-ref %outputs "out")))
+ #:parallel-build? #f
+ #:tests? #f ; no check target
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'unpack 'no (lambda _ #t))
+ (replace 'configure
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((dejavu (assoc-ref inputs "font-dejavu"))
+ (freedoom (assoc-ref outputs "out"))
+ (wad-dir (string-append freedoom "/share/games/doom")))
+ ;; Replace the font-searching function in a shell
+ ;; script with a direct path to the required font.
+ ;; This is necessary because ImageMagick can only find the
+ ;; most basic fonts while in the build environment.
+ (substitute* "graphics/titlepic/create_caption"
+ (("font=\\$\\(find_font.*$")
+ (string-append
+ "font=" dejavu
+ "/share/fonts/truetype/DejaVuSansCondensed-Bold.ttf\n")))
+ ;; Make icon creation reproducible.
+ (substitute* "dist/Makefile"
+ (("freedm.png")
+ "-define png:exclude-chunks=date freedm.png")
+ (("freedoom1.png")
+ "-define png:exclude-chunks=date freedoom1.png")
+ (("freedoom2.png")
+ "-define png:exclude-chunks=date freedoom2.png"))
+ ;; Make sure that the install scripts know where to find
+ ;; the appropriate WAD files.
+ (substitute* "dist/freedoom"
+ (("IWAD=freedm.wad")
+ (string-append "IWAD=" wad-dir "/freedm.wad"))
+ (("IWAD=freedoom1.wad")
+ (string-append "IWAD=" wad-dir "/freedoom1.wad"))
+ (("IWAD=freedoom2.wad")
+ (string-append "IWAD=" wad-dir "/freedoom2.wad")))
+ #t))))))
+ (native-inputs
+ `(("asciidoc" ,asciidoc)
+ ("deutex" ,deutex)
+ ("font-dejavu" ,font-dejavu)
+ ("imagemagick" ,imagemagick)
+ ("python" ,python-2)))
+ (inputs
+ `(("prboom-plus" ,prboom-plus)))
+ (home-page "https://freedoom.github.io/")
+ (synopsis "Free content game based on the Doom engine")
+ (description
+ "The Freedoom project aims to create a complete free content first person
+shooter game. Freedoom by itself is just the raw material for a game: it must
+be paired with a compatible game engine (such as @code{prboom-plus}) to be
+played. Freedoom complements the Doom engine with free levels, artwork, sound
+effects and music to make a completely free game.")
+ (license license:bsd-3)))
+
(define-public gnubg
(package
(name "gnubg")