aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-10-20 12:19:01 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-10-20 12:19:01 +0200
commitbe48b0549db4dfa0a406e2a136b02eb1035ed595 (patch)
tree74de14e0df7fa779405ec4303bece8b2806ed401 /gnu/packages
parent0da77d59b726c2392a824c9c1f7b11a763389c6e (diff)
downloadguix-be48b0549db4dfa0a406e2a136b02eb1035ed595.tar
guix-be48b0549db4dfa0a406e2a136b02eb1035ed595.tar.gz
gnu: emacs-ytdl: Small fixes.
* gnu/packages/emacs-xyz.scm (emacs-ytdl)[arguments]: End phases with #t. Use `make-file-writable' instead of `chmod'. [license]: Use GPL3+.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm27
1 files changed, 13 insertions, 14 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ddb2ccba0d..cf72cfa536 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -18788,8 +18788,7 @@ can be queued at any time.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32
- "1xv93ny942gha1ipic5r6z4icjsb7src7ssdck9983kks3zacjk7"))))
+ (base32 "1xv93ny942gha1ipic5r6z4icjsb7src7ssdck9983kks3zacjk7"))))
(build-system emacs-build-system)
(inputs
`(("youtube-dl" ,youtube-dl)))
@@ -18803,20 +18802,20 @@ can be queued at any time.")
(lambda* (#:key inputs #:allow-other-keys)
(let ((youtube-dl (assoc-ref inputs "youtube-dl")))
;; .el is read-only in git.
- (chmod "ytdl.el" #o644)
- ;; Specify the absolute file names of the various
- ;; programs so that everything works out-of-the-box.
- (emacs-substitute-variables
- "ytdl.el"
- ("ytdl-command"
- (string-append youtube-dl "/bin/youtube-dl")))))))))
+ (make-file-writable "ytdl.el")
+ ;; Specify the absolute file names of the various programs so
+ ;; that everything works out-of-the-box.
+ (emacs-substitute-variables "ytdl.el"
+ ("ytdl-command" (string-append youtube-dl "/bin/youtube-dl")))
+ #t))))))
(home-page "https://gitlab.com/tuedachu/ytdl")
(synopsis "Emacs interface for youtube-dl")
- (description "This package manages a video download queue for
-@command{youtube-dl}, which serves as the back end. New videos can be queued
-at any time. All youtube-dl backends are supported. It's possible to create
-download profiles depending on the downloaded URL.")
- (license license:gpl3)))
+ (description
+ "This package manages a video download queue for @command{youtube-dl},
+which serves as the back end. New videos can be queued at any time. All
+youtube-dl backends are supported. It is possible to create download profiles
+depending on the downloaded URL.")
+ (license license:gpl3+)))
(define-public emacs-org-web-tools
(package