aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 14:01:15 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commita195cd795f2d09f167ce68f3a75e9dee6845ae35 (patch)
tree09139ddb6fdce36f2f1b7bed28cd395455a6e2cb /gnu/packages
parenta311f5d00089287b1a6192f65397d93a932027c8 (diff)
downloadguix-a195cd795f2d09f167ce68f3a75e9dee6845ae35.tar
guix-a195cd795f2d09f167ce68f3a75e9dee6845ae35.tar.gz
gnu: Add ghc-blaze-html.
* gnu/packages/haskell.scm (ghc-blaze-html): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/haskell.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 4c52f02e72..c43bbdcd86 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -2030,6 +2030,31 @@ interoperate with code that uses the new implementation.")
library for Haskell.")
(license bsd-3)))
+(define-public ghc-blaze-html
+ (package
+ (name "ghc-blaze-html")
+ (version "0.8.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/blaze-html/blaze-html-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1dnw50kh0s405cg9i2y4a8awanhj3bqzk21jwgfza65kcjby7lpq"))))
+ (build-system haskell-build-system)
+ (arguments `(#:tests? #f)) ; FIXME: testing libraries are missing.
+ (propagated-inputs
+ `(("ghc-blaze-builder" ,ghc-blaze-builder)
+ ("ghc-text" ,ghc-text)
+ ("ghc-blaze-markup" ,ghc-blaze-markup)))
+ (home-page "http://jaspervdj.be/blaze")
+ (synopsis "Fast HTML combinator library")
+ (description "This library provides HTML combinators for Haskell.")
+ (license bsd-3)))
+
(define-public ghc-easy-file
(package
(name "ghc-easy-file")