aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2023-05-22 20:17:40 +0000
committerLudovic Courtès <ludo@gnu.org>2023-06-02 16:08:39 +0200
commitf1af4fbeecf753a299a3cc2a441da48ee4235b48 (patch)
treec9d885e7a346092fb6e89619fa683ef99a926058 /gnu/packages
parent53c47c4f285bf79d62fcf069b53fb34209e014e5 (diff)
downloadguix-f1af4fbeecf753a299a3cc2a441da48ee4235b48.tar
guix-f1af4fbeecf753a299a3cc2a441da48ee4235b48.tar.gz
gnu: python-ipython-documentation: Remove patches.
* gnu/packages/python-xyz.scm (python-ipython-documentation)[source]: Remove upstreamed patches. * gnu/packages/patches/python-ipython-documentation-chars.patch, gnu/packages/patches/python-ipython-documentation-repro.patch: Delete files. * gnu/local.mk: Remove files. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/patches/python-ipython-documentation-chars.patch18
-rw-r--r--gnu/packages/patches/python-ipython-documentation-repro.patch25
-rw-r--r--gnu/packages/python-xyz.scm7
3 files changed, 0 insertions, 50 deletions
diff --git a/gnu/packages/patches/python-ipython-documentation-chars.patch b/gnu/packages/patches/python-ipython-documentation-chars.patch
deleted file mode 100644
index a52c54f513..0000000000
--- a/gnu/packages/patches/python-ipython-documentation-chars.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Avoid LaTeX errors due to non-printable characters.
-Submitted upstream: https://github.com/ipython/ipython/pull/13640
-
-diff --git a/IPython/utils/coloransi.py b/IPython/utils/coloransi.py
-index e33142180..9300b0108 100644
---- a/IPython/utils/coloransi.py
-+++ b/IPython/utils/coloransi.py
-@@ -74,8 +74,8 @@ class TermColors:
- class InputTermColors:
- """Color escape sequences for input prompts.
-
-- This class is similar to TermColors, but the escapes are wrapped in \001
-- and \002 so that readline can properly know the length of each line and
-+ This class is similar to TermColors, but the escapes are wrapped in \\001
-+ and \\002 so that readline can properly know the length of each line and
- can wrap lines accordingly. Use this class for any colored text which
- needs to be used in input prompts, such as in calls to raw_input().
-
diff --git a/gnu/packages/patches/python-ipython-documentation-repro.patch b/gnu/packages/patches/python-ipython-documentation-repro.patch
deleted file mode 100644
index d6a6e9c3fd..0000000000
--- a/gnu/packages/patches/python-ipython-documentation-repro.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-Fix non-reproducibilities caused by time-dependent procedures.
-Submitted upstream: https://github.com/ipython/ipython/pull/13640
-
-diff --git a/IPython/sphinxext/ipython_directive.py b/IPython/sphinxext/ipython_directive.py
-index 18bdfcae9..2c665ac87 100644
---- a/IPython/sphinxext/ipython_directive.py
-+++ b/IPython/sphinxext/ipython_directive.py
-@@ -19,7 +19,7 @@
- In [1]: 1+1
-
- In [1]: import datetime
-- ...: datetime.datetime.now()
-+ ...: datetime.date.fromisoformat('2022-02-22')
-
- It supports IPython construct that plain
- Python does not understand (like magics):
-@@ -28,7 +28,7 @@
-
- In [0]: import time
-
-- In [0]: %timeit time.sleep(0.05)
-+ In [0]: %pdoc time
-
- This will also support top-level async when using IPython 7.0+
-
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 22f8e91314..78312021d7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10457,13 +10457,6 @@ computing.")
(inherit python-ipython)
(name "python-ipython-documentation")
(version (package-version python-ipython))
- (source
- (origin
- (inherit (package-source python-ipython))
- (patches (append (search-patches
- "python-ipython-documentation-chars.patch"
- "python-ipython-documentation-repro.patch")
- (origin-patches (package-source python-ipython))))))
(arguments
(list
#:phases