aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-15 18:21:47 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-15 18:21:47 +0200
commitf8e0d93ca3424a3be238b211501cef84a151ec7b (patch)
treeb61e7ef35653a20719d07fbaa913bf45cbacaf90 /gnu/packages
parent0b58cb427db55ec710d54330191cf9b4ebab3e6e (diff)
downloadguix-f8e0d93ca3424a3be238b211501cef84a151ec7b.tar
guix-f8e0d93ca3424a3be238b211501cef84a151ec7b.tar.gz
gnu: salmon: Fix build with GCC 7.
* gnu/packages/bioinformatics.scm (salmon)[arguments]: Do not read from CPLUS_INCLUDE_PATH, and add headers to CPATH only.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioinformatics.scm7
1 files changed, 2 insertions, 5 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 0dcbb94666..1372bb411a 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11874,14 +11874,11 @@ The following file formats are supported:
(("lib/libdivsufsort.a") "/lib/libdivsufsort.so"))
;; Ensure that all headers can be found
- (setenv "CPLUS_INCLUDE_PATH"
- (string-append (getenv "CPLUS_INCLUDE_PATH")
+ (setenv "CPATH"
+ (string-append (getenv "CPATH")
":"
(assoc-ref inputs "eigen")
"/include/eigen3"))
- (setenv "CPATH"
- (string-append (assoc-ref inputs "eigen")
- "/include/eigen3"))
#t))
;; CMAKE_INSTALL_PREFIX does not exist when the tests are
;; run. It only exists after the install phase.