aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2016-06-12 23:23:23 +0200
committerRoel Janssen <roel@gnu.org>2016-06-12 23:37:12 +0200
commitd95e8e0170f7d4f9c50921379e89192425a65038 (patch)
tree471c22a607bc69a8223ef2e2ee4d32d85eb3f735 /gnu/packages
parent6e46836c76ffb5ce26ceb336e27d12de92980450 (diff)
downloadguix-d95e8e0170f7d4f9c50921379e89192425a65038.tar
guix-d95e8e0170f7d4f9c50921379e89192425a65038.tar.gz
gnu: Add emacs-rainbow-identifiers.
* gnu/packages/emacs.scm (emacs-rainbow-identifiers): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 1f1d201a32..6a79412f7b 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2016 Matthew Jordan <matthewjordandevops@yandex.com>
+;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1933,6 +1934,28 @@ matching delimiters, orient yourself in the code, and tell which statements
are at a given level.")
(license license:gpl3+)))
+(define-public emacs-rainbow-identifiers
+ (package
+ (name "emacs-rainbow-identifiers")
+ (version "0.2.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://raw.githubusercontent.com/Fanael"
+ "/rainbow-identifiers/" version
+ "/rainbow-identifiers.el"))
+ (file-name (string-append "rainbow-identifiers-" version ".el"))
+ (sha256
+ (base32
+ "0325abxj47k0g1i8nqrq70w2wr6060ckhhf92krv1s072b3jzm31"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/Fanael/rainbow-identifiers")
+ (synopsis "Highlight identifiers in source code")
+ (description
+ "Rainbow identifiers mode is an Emacs minor mode providing highlighting of
+identifiers based on their names. Each identifier gets a color based on a hash
+of its name.")
+ (license license:bsd-2)))
+
(define-public emacs-ido-completing-read+
(package
(name "emacs-ido-completing-read+")