aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-06-08 18:17:13 -0400
committerMark H Weaver <mhw@netris.org>2016-06-08 18:17:13 -0400
commit993b400acb24344d399857010177e7ecaab847b7 (patch)
treed834031fb13adc817f0b4227cb3e54d3ce5493b0 /gnu/packages
parent6e4f18cfdd1bf747e77f81b64497f1c05f57a057 (diff)
downloadguix-993b400acb24344d399857010177e7ecaab847b7.tar
guix-993b400acb24344d399857010177e7ecaab847b7.tar.gz
Revert "gnu: libxml2: Add fix for CVE-2016-1762."
This reverts commit 6e4f18cfdd1bf747e77f81b64497f1c05f57a057.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/patches/libxml2-CVE-2016-1762.patch31
-rw-r--r--gnu/packages/xml.scm3
2 files changed, 1 insertions, 33 deletions
diff --git a/gnu/packages/patches/libxml2-CVE-2016-1762.patch b/gnu/packages/patches/libxml2-CVE-2016-1762.patch
deleted file mode 100644
index 15ec6a0aee..0000000000
--- a/gnu/packages/patches/libxml2-CVE-2016-1762.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-Copied from Debian.
-
-From a7a94612aa3b16779e2c74e1fa353b5d9786c602 Mon Sep 17 00:00:00 2001
-From: Daniel Veillard <veillard@redhat.com>
-Date: Tue, 9 Feb 2016 12:55:29 +0100
-Subject: [PATCH] Heap-based buffer overread in xmlNextChar
-
-For https://bugzilla.gnome.org/show_bug.cgi?id=759671
-
-when the end of the internal subset isn't properly detected
-xmlParseInternalSubset should just return instead of trying
-to process input further.
-
-[carnil: drop patches to testsuite files]
----
-
-diff --git a/parser.c b/parser.c
-index c5741e3..0677030 100644
---- a/parser.c
-+++ b/parser.c
-@@ -8468,6 +8468,7 @@ xmlParseInternalSubset(xmlParserCtxtPtr ctxt) {
- */
- if (RAW != '>') {
- xmlFatalErr(ctxt, XML_ERR_DOCTYPE_NOT_FINISHED, NULL);
-+ return;
- }
- NEXT;
- }
---
-2.8.1
-
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 40ff3e6b4b..dc5c60dca8 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -116,8 +116,7 @@ project (but it is usable outside of the Gnome platform).")
version ".tar.gz"))
(sha256
(base32
- "0g336cr0bw6dax1q48bblphmchgihx9p1pjmxdnrd6sh3qci3fgz"))
- (patches (search-patches "libxml2-CVE-2016-1762.patch")))))))
+ "0g336cr0bw6dax1q48bblphmchgihx9p1pjmxdnrd6sh3qci3fgz")))))))
(define-public python-libxml2
(package (inherit libxml2)