aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-03-30 11:30:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-03-30 21:38:38 +0200
commit254b3310501e42f0bf4f016f46881fc3cbea7c5d (patch)
tree44b9cfd9658f273b23aa73f3ad94febd0885110b /gnu/packages
parent3c5e1412e3ef769df8e4826d0aedabaa3aa0d631 (diff)
downloadguix-254b3310501e42f0bf4f016f46881fc3cbea7c5d.tar
guix-254b3310501e42f0bf4f016f46881fc3cbea7c5d.tar.gz
gnu: minicom: Update to 2.8.
* gnu/packages/engineering.scm (minicom): Update to 2.8.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/engineering.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 8d7ba9c1da..57464e1834 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2016, 2017, 2018, 2019, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016, 2017, 2018 Theodoros Foradis <theodoros@foradis.org>
;;; Copyright © 2017 Julien Lepiller <julien@lepiller.eu>
-;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2018, 2019 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;; Copyright © 2018, 2019, 2020 Arun Isaac <arunisaac@systemreboot.net>
@@ -1248,7 +1248,7 @@ replacement for the OpenDWG libraries.")
(define-public minicom
(package
(name "minicom")
- (version "2.7.1")
+ (version "2.8")
(source
(origin
(method git-fetch)
@@ -1256,13 +1256,16 @@ replacement for the OpenDWG libraries.")
(url "https://salsa.debian.org/minicom-team/minicom.git")
(commit (string-append "v" version))))
(sha256
- (base32 "0f36wv015zpz1x895qv0z6marlynzyh0d5mfkyd7lfyy2xd1i2w0"))
+ (base32 "0kfihxbh9qkjk9m1932ajyqx384c2aj3d9yaphh3i9i7y1shxlpx"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags '("--enable-lock-dir=/var/lock")
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'make-git-checkout-writable
+ (lambda _
+ (for-each make-file-writable (find-files "."))))
(replace 'bootstrap
;; autogen.sh needlessly hard-codes aclocal-1.14.
(lambda _