aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-04-01 08:02:28 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-05-31 04:54:57 +0200
commit6c4d1413f2f800ac277ada50e9c1c657b3ed4bfb (patch)
treeca954a31e17087792dc47194db501a230783adec /gnu/packages
parent8d5960d1b16550d352324ac2d212141a7806fa76 (diff)
downloadguix-6c4d1413f2f800ac277ada50e9c1c657b3ed4bfb.tar
guix-6c4d1413f2f800ac277ada50e9c1c657b3ed4bfb.tar.gz
gnu: mkvtoolnix: Use INVOKE.
* gnu/packages/video.scm (mkvtoolnix)[arguments]: Substitute INVOKE for SYSTEM*.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/video.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 0a5f0b438a..4dd3e5a1ee 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -368,13 +368,13 @@ H.264 (MPEG-4 AVC) video streams.")
(replace 'build
(lambda _
(let ((-j (list "-j" (number->string (parallel-job-count)))))
- (zero? (apply system* "rake" -j)))))
+ (apply invoke "rake" -j))))
(replace 'check
(lambda _
- (zero? (system* "rake" "tests/unit"))))
+ (invoke "rake" "tests/unit")))
(replace 'install
(lambda _
- (zero? (system* "rake" "install")))))))
+ (invoke "rake" "install"))))))
(home-page "https://mkvtoolnix.download")
(synopsis "Tools to create, alter and inspect Matroska files")
(description