aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-04-01 07:46:17 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-05-31 04:54:54 +0200
commit16b5dafc4db79e0ebf6dbe48d0ed21c25d82edfe (patch)
tree48d52fa363bbfbf41fba7d00e3da26e35070a179 /gnu/packages
parent2cdc719193a2f77cf972219bd4f50eb152fb575f (diff)
downloadguix-16b5dafc4db79e0ebf6dbe48d0ed21c25d82edfe.tar
guix-16b5dafc4db79e0ebf6dbe48d0ed21c25d82edfe.tar.gz
gnu: httptunnel: Use INVOKE.
* gnu/packages/web.scm (httptunnel)[arguments]: Substitute INVOKE for SYSTEM*.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/web.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 0fe9c5bdec..5a87eb5f6e 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -4889,8 +4889,8 @@ on the fly.")
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out")))
(setenv "CONFIG_SHELL" (which "bash"))
- (zero? (system* "./configure"
- (string-append "--prefix=" out)))))))))
+ (invoke "./configure"
+ (string-append "--prefix=" out))))))))
(home-page "http://www.nocrew.org/software/httptunnel.html")
(synopsis "Tunnel data connections through HTTP requests")
(description "httptunnel creates a bidirectional virtual data connection