aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2019-04-06 10:34:40 -0400
committerKei Kebreau <kkebreau@posteo.net>2019-04-20 16:40:35 -0400
commita3e6cf987684cc7476b6ee544091c464378cbcd9 (patch)
treec811406f58717a670ea387026648aa34ea9b5588 /gnu/packages
parentafabb9ecfb2776e70717b5b84f4aa694ffb02b8b (diff)
downloadguix-a3e6cf987684cc7476b6ee544091c464378cbcd9.tar
guix-a3e6cf987684cc7476b6ee544091c464378cbcd9.tar.gz
gnu: Add git-lfs.
* gnu/packages/version-control.scm (git-lfs): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/version-control.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 22771a129c..3432e70c1b 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2018 Timothy Sample <samplet@ngyro.com>
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2019 Jovany Leandro G.C <bit4bit@riseup.net>
+;;; Copyright © 2019 Kei Kebreau <kkebreau@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -47,6 +48,7 @@
#:use-module (guix git-download)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system go)
#:use-module (guix build-system python)
#:use-module (guix build-system trivial)
#:use-module (gnu packages apr)
@@ -2144,3 +2146,27 @@ design goals are to reduce the pain of resolving merge conflicts by finding
the smallest possible conflicts and to allow a merge to be saved, tested,
interrupted, published, and collaborated on while in progress.")
(license license:gpl2+)))
+
+(define-public git-lfs
+ (package
+ (name "git-lfs")
+ (version "2.7.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/git-lfs/git-lfs")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "10v38w8qfz0x8750kv31n8gg2dimvq4wz40m374pd1xaypfs9670"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/git-lfs/git-lfs"))
+ (home-page "https://git-lfs.github.com/")
+ (synopsis "Git extension for versioning large files")
+ (description
+ "Git Large File Storage (LFS) replaces large files such as audio samples,
+videos, datasets, and graphics with text pointers inside Git, while storing the
+file contents on a remote server.")
+ (license license:expat)))