aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorng0 <contact.ng0@cryptolab.net>2017-03-04 14:09:32 +0000
committerLeo Famulari <leo@famulari.name>2017-03-04 17:51:04 -0500
commitd0c16adb190c7244ee3ef1329cba78a015ae5d10 (patch)
treecd25262485b5b1c22552663028892d069469300c /gnu/packages
parent34ba7cd4ebbaf0a597a0254cd7d675be23e28ccc (diff)
downloadguix-d0c16adb190c7244ee3ef1329cba78a015ae5d10.tar
guix-d0c16adb190c7244ee3ef1329cba78a015ae5d10.tar.gz
gnu: gitolite: Fix shebangs in hooks.
Fixes <https://bugs.gnu.org/25957>. * gnu/packages/version-control.scm (gitolite)[arguments]: Add 'fix-hooks-shebangs' phase to fix references to '/usr/bin/perl'. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/version-control.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 1076c18905..ccda00173d 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -616,6 +616,17 @@ also walk each side of a merge and test those changes individually.")
(substitute* (find-files "." ".*")
((" perl -")
(string-append " " perl " -"))))))
+ (add-before 'install 'fix-hooks-shebangs
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((perl (string-append (assoc-ref inputs "perl")
+ "/bin/perl")))
+ ;; The files in 'lib/Gitolite/Hooks' keep references to
+ ;; '/usr/bin/perl', without this fix it is impossible to
+ ;; to run gitolite in production.
+ (substitute* (find-files "src/lib/Gitolite/Hooks" ".*")
+ (("/usr/bin/perl")
+ perl))
+ #t)))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((output (assoc-ref outputs "out"))