aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-01-24 01:59:07 -0500
committerLeo Famulari <leo@famulari.name>2017-01-24 01:59:51 -0500
commitb2725c53dd4cce2421845736df7940289c32f8a7 (patch)
tree58df20e388418bd5caa7f731b08fcb14819906c7 /gnu/packages
parent4cfd222fa7b4df34e8fc002cf572be86d887f5bd (diff)
downloadguix-b2725c53dd4cce2421845736df7940289c32f8a7.tar
guix-b2725c53dd4cce2421845736df7940289c32f8a7.tar.gz
gnu: khal: Update to 0.9.0.
* gnu/packages/calendar.scm (khal): Update to 0.9.0 [source]: Remove obsolete patch. * gnu/packages/patches/khal-disable-failing-tests.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/calendar.scm5
-rw-r--r--gnu/packages/patches/khal-disable-failing-tests.patch33
2 files changed, 2 insertions, 36 deletions
diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
index 70bf8f9573..03898dd263 100644
--- a/gnu/packages/calendar.scm
+++ b/gnu/packages/calendar.scm
@@ -84,14 +84,13 @@ data units.")
(define-public khal
(package
(name "khal")
- (version "0.8.4")
+ (version "0.9.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "khal" version))
- (patches (search-patches "khal-disable-failing-tests.patch"))
(sha256
(base32
- "03vy4dp9n43w51mwqjjy08dr5nj7wxqnb085visz3j43vzm42p1f"))))
+ "138gxynw7zavwqqaw5nzmj8sbpkymmb95xzgxqbdi9fiiqm9kamr"))))
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
diff --git a/gnu/packages/patches/khal-disable-failing-tests.patch b/gnu/packages/patches/khal-disable-failing-tests.patch
deleted file mode 100644
index e2c65df8ce..0000000000
--- a/gnu/packages/patches/khal-disable-failing-tests.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-Disable some tests that are known to fail:
-
-https://github.com/pimutils/khal/issues/546
-https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=844081
-
-diff --git a/tests/khalendar_test.py b/tests/khalendar_test.py
-index fd8dcc6..17732bf 100644
---- a/tests/khalendar_test.py
-+++ b/tests/khalendar_test.py
-@@ -65,6 +65,7 @@ class TestCalendar(object):
- else:
- mtimes[cal] = mtime
-
-+ @pytest.mark.xfail
- def test_db_needs_update(self, coll_vdirs):
- coll, vdirs = coll_vdirs
-
-@@ -321,6 +322,7 @@ class TestDbCreation(object):
- CalendarCollection(calendars, dbpath=dbpath, locale=aux.locale)
-
-
-+@pytest.mark.xfail
- def test_default_calendar(coll_vdirs):
- """test if an update to the vdir is detected by the CalendarCollection"""
- coll, vdirs = coll_vdirs
-@@ -341,6 +343,7 @@ def test_default_calendar(coll_vdirs):
- assert len(list(coll.get_events_on(today))) == 0
-
-
-+@pytest.mark.xfail
- def test_only_update_old_event(coll_vdirs, monkeypatch):
- coll, vdirs = coll_vdirs
-